Overclock.net banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4,337 Posts
Discussion Starter #1
Hello OCN,

I have a Lenovo 50-70 with an Nvidia 840M GPU. I never had any issues with gaming on this laptop until I upgraded to Windows 10 last year and I began to notice a glaring issue.

The effect is quite simple to explain. Many of my 3D apps continue to work exactly as before, including:

-Skyrim
-Trine
-Portal 2
-GW2
-Torchlight 2
-Total War Series
-World of Warships

Unfortunately the following games will load up with no visual (sometimes border-less window). I re-iterate that the app. does in fact load up. The adverts, menu music etc. all work fine, but there are no visuals:

-Elder Scrolls Online
-Steam Big Picture
-Lara Croft
-World of Warcraft
-Witcher 3

I have re-installed drivers a few times, including rolling back to older ones, and running games in compatibility mode or switching from OpenGL to DirectX, but nothing so far made a difference. I can't find a similar problem online either (or I am not searching correctly).

I'll add some more to the list if I have time to test, hopefully someone can notice the demarcation between the two sets. I've had this issue for a while now and I'm contemplating reverting to Win8 or re-installing Win10.

Kind Regards.
 

·
Registered
Joined
·
4,337 Posts
Discussion Starter #3
Could be... I sometimes plug my laptop into an HDMI monitor.

Some of the games are fresh installs though, so I don't see how they can be directed to the HDMI when I've never played them with it connected. (I re-installed ESO, and WoW was installed to test.)

At the moment WoW loads up and forces me into a small, black, borderless window whenever I select it - as if it is stuck in a resolution that is not functionable . I can hear the game sounds and the feedback from keyboard inputs, I can even see the gauntlet-shaped cursor... but no video.

How can I be sure and what could I do about this?
 
1 - 3 of 3 Posts
Top