Overclock.net banner

Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
529 Posts
Discussion Starter · #1 ·
So I've had my 670 FTW for almost a year now and haven't had any problems. Recently (about a week ago), I upgraded to water cooling and got a waterblock for it. It started off working great, but I'm starting to have tons of problems now. Everything single time I play a game (mostly Skyrim) or run a benchmark like Heaven, the GPU underclocks itself like crazy. This usually results in a ~40fps drop. When I quit the game or benchmark, I then get a message saying "Nvidia Display Driver Has Stopped Responding and Successfully Recovered". I usually then have to restart my computer.

I am really confused right now on what to do. My temps are fine (usually around 35c, never over 40c). I do have the card overclocked (1293MHz core clock and 3856Mhz memory clock). I've tried lowering the clocks down, but that doesn't help either. I also should mention that I have the latest drivers installed (314.07). Lastly, I've been using Precision X to overclock, and everytime I restart my computer, the voltage goes back to stock after I've bumped it up. Anyone know why? Thanks
smile.gif


EDIT:It seems my GPU wasn't properly seated. I cannot seem to get it to fit right. It doesn't make that click sound, and the pins on the side of the slot on the mobo only go down about halfway. What can I do to fit this? Nothing seems to be working!!!
 

·
Registered
Joined
·
1,153 Posts
Well, I am not sure it's the drivers, I am running 314.07 as well without issue. It could be that you just need to re-seat the graphics card. I have had that happen before with my old 460.
 

·
Registered
Joined
·
529 Posts
Discussion Starter · #3 ·
Quote:
Originally Posted by 0CALEFACTION0 View Post

Well, I am not sure it's the drivers, I am running 314.07 as well without issue. It could be that you just need to re-seat the graphics card. I have had that happen before with my old 460.
I've tried that already with no luck. But I'll give it another go.

EDIT: looks like you were right; the card isn't all the way down. But I cannot get it to go all the way down. The pins are like halfway down (haven't heard that click yet either). Any tips on how I could get the card to go in?
 

·
Registered
Joined
·
1,153 Posts
Quote:
Originally Posted by YouGotJaked View Post

I've tried that already with no luck. But I'll give it another go.

EDIT: looks like you were right; the card isn't all the way down. But I cannot get it to go all the way down. The pins are like halfway down (haven't heard that click yet either). Any tips on how I could get the card to go in?
Hmm, I would be afraid to apply too much pressure. A PCI slot doesn't necessarily click. As long as you try to seat it as far as possible and slide the lock over it you should be golden.
 

·
Registered
Joined
·
529 Posts
Discussion Starter · #5 ·
Quote:
Originally Posted by 0CALEFACTION0 View Post

Hmm, I would be afraid to apply too much pressure. A PCI slot doesn't necessarily click. As long as you try to seat it as far as possible and slide the lock over it you should be golden.
Ok well it's in there so maybe it's a different problem? Do you have any other suggestions on what it could be?
 

·
Registered
Joined
·
1,153 Posts
Quote:
Originally Posted by YouGotJaked View Post

Ok well it's in there so maybe it's a different problem? Do you have any other suggestions on what it could be?
Try installing the drivers again but this time make it a clean install, if you have any profiles set it will remove them, but it's for the best. However, I assume you may have already done this. At that point I do not know what to tell you.
 

·
Registered
Joined
·
529 Posts
Discussion Starter · #7 ·
Quote:
Originally Posted by 0CALEFACTION0 View Post

Try installing the drivers again but this time make it a clean install, if you have any profiles set it will remove them, but it's for the best. However, I assume you may have already done this. At that point I do not know what to tell you.
Hmm ok I'll try reinstalling the drivers.
 

·
Twitch Streamer
Joined
·
2,531 Posts
I get this same problem, but i find it has to do with the driver i was using. I have installed probably every single driver Nvidia has release WHQL and Beta, since R275 and i found 306.97 to be the most stable for me (very rare TDR's, crashes, artifacts in BF3). But i did notice i had a lot of display driver crashing with the R314, 310, 285, 301 drivers.

Im not sure; i dont what to tell you at this point. NVidia has some pretty unstable drivers that ive used that have actually made my card perform worse than before... (R310 drivers compared to 306). It may not be a graphics card issue, it may just be a driver issue.

But thats just my two cents. Hope you find the source of your problem!
 

·
Registered
Joined
·
529 Posts
Discussion Starter · #9 ·
Quote:
Originally Posted by Aesthethc View Post

I get this same problem, but i find it has to do with the driver i was using. I have installed probably every single driver Nvidia has release WHQL and Beta, since R275 and i found 306.97 to be the most stable for me (very rare TDR's, crashes, artifacts in BF3). But i did notice i had a lot of display driver crashing with the R314, 310, 285, 301 drivers.

Im not sure; i dont what to tell you at this point. NVidia has some pretty unstable drivers that ive used that have actually made my card perform worse than before... (R310 drivers compared to 306). It may not be a graphics card issue, it may just be a driver issue.

But thats just my two cents. Hope you find the source of your problem!
Did a reinstall of my drivers and no problems so far. Hopefully that was the issue and everything is back to normal now.
 

·
Twitch Streamer
Joined
·
2,531 Posts
Quote:
Originally Posted by YouGotJaked View Post

Did a reinstall of my drivers and no problems so far. Hopefully that was the issue and everything is back to normal now.
Sometimes they come back after a while... im using 306.23 and so far ive only had one crash and maybe some artifacts of terrain not loading in the distance. other than that it seems pretty stable. you may just need to work around with drivers till you find the one that works for you!
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top