Overclock.net banner

1 - 20 of 68 Posts

·
Registered
Joined
·
804 Posts
Discussion Starter #1
Hey,

I'm having a problem lately, with Direct3D. I have the latest version of DX9 Oct. dxdiag found no corruption or issue's with the DX Files. Direct Draw works and so does everything else except Direct3D, the games that I used to play everyday don't work now, on dxdia when I test Direct3D.

The Log Shows Below.

Code:
Code:
Direct3D 7 test results: Failure at step 8 (Creating 3D Device): HRESULT = 0x887602eb (error code)
Direct3D 8 test results: Failure at step 8 (Creating 3D Device): HRESULT = 0x8876086a (3D not available)
Direct3D 9 test results: Failure at step 8 (Creating 3D Device): HRESULT = 0x8876086a (3D not available)
Please I really need help with this, I have been having it for a month and It just showed up..
i dont even know if its in the right section..
 

·
Registered
Joined
·
804 Posts
Discussion Starter #5
i found the problem, whenever i uninstall my creative sound console (drivers) it seems to be working perfectly fine...now i installed it back and the issue is back! what should i do??
 

·
Registered
Joined
·
2,431 Posts
Quote:

Originally Posted by Frozen-Liquid View Post
i found the problem, whenever i uninstall my creative sound console (drivers) it seems to be working perfectly fine...now i installed it back and the issue is back! what should i do??
look for updated creative drivers?

I had a similar problem when trying to install an Audigy SE on a Dell machine, it gave me a BSOD immediately on startup after installing the creative drivers+software. I ended up having to use a generic Creative driver without all the extra software...
 

·
Registered
Joined
·
804 Posts
Discussion Starter #9
okay, the kxdrivers dont work, so now i have to choose, my GX2 or Xi-Fi...the only way i can create 3D objects is when the sound card is disabled. and the 8oo mb. worth of software deleted. my sound card is at the bottom slot, on top of that is my wireless internet (antennae) and then my neon lights I/O then my Coolermaster fan controller and finally the GX2. i have enough power in my PSU but is the slot a problem? i heard that creative is infamouse for being in the last slot?
 

·
Registered
Joined
·
804 Posts
Discussion Starter #12
ok thX ill try that, also whenever i disable mult-gpu function (sli) everything else works fine, halflife2 everything, but when i enable it, BSOD and no direct 3D or agp accelerator, do i enable PEG thing??
 

·
Registered
Joined
·
749 Posts
make sure you disable peg link in your bios, this could be your problem. It caused my 7800GT to lock up every 30 sec.
 

·
Registered
Joined
·
804 Posts
Discussion Starter #17
yes i know how to do that, right now its on auto, should I disable? will it hinder performance. I tried that but nothing different happened so I put it back on auto, so know i play games on single GPU, I wasted money?! I hope someone could help thanks everyone REP+
 

·
Registered
Joined
·
749 Posts
peg link is basically something that tries to automatically overclock your gpu for you. If you disable it, it is actually will help performance and allow you to overclock higher. You shouldn't notice anything when you disable it but I noticed that I could overclock much higher when I disabled it. So I would say disable it, it won't hurt performance at all and it might clear up your problems. Also, I don't know if this is only a problem with the A8N32-sli's but your memory will become unstable unless you turn off legacy usb support. No harm in trying. Hopes this helps
.
 

·
Registered
Joined
·
804 Posts
Discussion Starter #19
ill try disabling it, but I dont think memory is the problem? it used to work perfectly before, i dont know what happened..ever since i installed hitman blood money..but SLi will not execute direct3D thats the issue i believe. single gpu is on at the moment but i want multi!! i did a windows repair console and gonna disable again PEG link and legacy, will get back at u and tell u results and what i see maybe could help in BIOS. thX
 

·
Registered
Joined
·
749 Posts
wait, ur trying to do SLI with one 7950GX2? Cuz if you only have one 7950GX2, it is recognized as one card not as two put together. Do you see what I mean. The 7950 GX2 is a single graphics card that works by having two lesser gpus act as one greater one. So, long story short, if you have one GX2, then don't enable SLI! It will work fine when you have sli disabled.
If you need any more help just ask.
 
1 - 20 of 68 Posts
Top