Overclock.net banner
3061 - 3080 of 3080 Posts

·
Retired Moderation
Joined
·
10,698 Posts
I just stopped by the club to say tomorrow I pull the plug on a 4K panel and handing down my U2713HM to the second rig. Considering I purchased the monitor in May 2013 I'd say this has been a great purchase as it's value continues.
smile.gif


I can now say after owning my first Dell monitor I've been and am impressed, especially with customer service that makes things right and free cross shipping RMA's. My next monitor would have been a Dell but they don't have a 4K IPS Async monitor yet and I'm ready to make the 4K leap.
 

·
Premium Member
Joined
·
16,114 Posts
I'm still rocking mine
biggrin.gif
. I'm actually trying to hold out for either an IPS 21:9 100hz display from them or another 1440p display with 144hz, IPS, etc. This waiting thing is hard
redface.gif
.
 

·
Registered
Joined
·
64 Posts
Hello !

This is a great monitor . Had almost no tearing in w7 with 6870 windforce on DVI-D , but now on w10 with a new msi 390 , last crimson driver in rome 2 I get massive tearing , with vsync, half of tearing disapears but half remains, game is unplayable. I wonder if I can oc the monitor , maybe I can get more tearing out. Would a display port help ?
 

·
Premium Member
Joined
·
8,166 Posts
Discussion Starter · #3,064 ·
Quote:
Originally Posted by aandredor View Post

Hello !

This is a great monitor . Had almost no tearing in w7 with 6870 windforce on DVI-D , but now on w10 with a new msi 390 , last crimson driver in rome 2 I get massive tearing , with vsync, half of tearing disapears but half remains, game is unplayable. I wonder if I can oc the monitor , maybe I can get more tearing out. Would a display port help ?
The monitor is not overclockable.

I doubt changing interface would help but it's worth a try. Also try setting a hard framerate limit using something like Afterburner, rather than VSync.
 

·
Registered
Joined
·
64 Posts
Had tried the msi frame limiter but same problem I see windows 10 gives a driver for u2713hm from 08.08.2012 , revision 2.0.0.0 .Also can't find another driver on dell site to download . Anyone that still has the u2713hm has the same driver ?
 

·
Registered
Joined
·
3 Posts
Quote:
Originally Posted by avijani View Post

Can anyone confirm this to me, i have U2713HM that i smashed (don't ask why), and i need panel. I dissasemble screen and i got this:
LTM270DL02 (-D01, C02) and according to code this is Samsung panel.

Can i switch to LG panel (more options, if i have more panels to choose) or i have to stick with this hard to find Samsung?

Thanks.
I found this screen (at least same PN) on ICT sales site in UK. Ordered one (although it's for XPS One, and glossy), price was good compared to other offers i got. Shipping was fast, and after 5 days i got screen.

I already disassembled U2713Hm so i only got to fit new screen.

  1. New screen had "hinges" on both sides, but they are just 2 screws and they are out
  2. New screen is glossy, but this isn't big issue for me, i wanted IPS just for games and multimedia
  3. New screen and old screen had different cables. Flat cable was little bit left and i have to adjust postioning on the back, also new LED cable was short, but they have same connectors so i retrofit
Othere than these 3 things, everything was straight "bolt on". After assembly, i fired up monitor, everything works ok. So if you have broken like i had, you can ping those guys and replace screen for yourself. It's lot cheaper than get new one (~500eur + VAT in my case).

Here is screen.
 

·
Registered
Joined
·
75 Posts
About 1 year since I last visited this thread.

I really enjoy the colors of my display, but the inverse ghost really kills it for me. So, anyone discovered a way to reduce the ghosting/overclocking? IF not I think I may send it back to Dell.
 

·
Registered
Joined
·
210 Posts
My monitor is out of warranty and 60hz is plenty for me, but just for future reference and clarification is the monitor overclockable or not? also does it void the warranty.
 

·
Registered
Joined
·
10 Posts
yes, its overclockable, mine went up to 90Hz, but already at ~85Hz i saw artifacts on the Screen (flickering Pixels appearing White instead of black) and any overclocking will void your warranty.
 

·
Registered
Joined
·
3 Posts
HI guys,

I have one question for those who own Dell U2715H or any similar model.

I recently got this monitor and I'm not sure if my monitor is defected or not. The picture is crystal clear and colors really pop, but when standing or moving left /right to the side when sitting the display fades in the corners. colours fades, kinda greyish. .... dont know how to explain. it's wierd because this does not happen on older,cheaper dell 24, also IPS.

Is that normal with this model or it's defected?
 

·
Premium Member
Joined
·
16,114 Posts
Quote:
Originally Posted by alcahofa View Post

HI guys,

I have one question for those who own Dell U2715H or any similar model.

I recently got this monitor and I'm not sure if my monitor is defected or not. The picture is crystal clear and colors really pop, but when standing or moving left /right to the side when sitting the display fades in the corners. colours fades, kinda greyish. .... dont know how to explain. it's wierd because this does not happen on older,cheaper dell 24, also IPS.

Is that normal with this model or it's defected?
If you can try and post a picture. It sounds almost like you're seeing part of the anti-glare coating. It could possibly be badly applied near the edges?
 

·
Registered
Joined
·
8 Posts
I have a wonderfull 2713HM working perfect a lot of years....

I want to purchase a 2715H now..... anyone have this monitor? I only need to know if the colors are as vivid and intense as the 2713hm Model.

Can someone help me?

Thanks!!
 

·
Premium Member
Joined
·
16,114 Posts
Quote:
Originally Posted by alcahofa View Post

imag0644.jpg

Is it suppose to be like this?
imag0646.jpg

~180 angle, it's fine.
I'll check my monitor when I get home, but keep in mind, this is a thread for the 2713, and I believe you said you have the 2715, correct?
 

·
Registered
Joined
·
3 Posts
Correct. But U2715H, its like an upgraded version of 2713HM, something like that? Did not want to open a new one, since they are quite a like.
 

·
Premium Member
Joined
·
16,114 Posts
Quote:
Originally Posted by alcahofa View Post

Correct. But U2715H, its like an upgraded version of 2713HM, something like that? Did not want to open a new one, since they are quite a like.
Well I also wanted to clarify as to ensure I didn't blanket a statement later on that might only be true for the 2713. They are similar from what I understand, but an anti-glare coating is something that can find a way to be changed across small model number jumps. I will check when I get home later, but I do believe some of the user's here did get 2715s.

Mine is being used on my GFs computer ATM, so I'm not using it every day as I was a few months ago.
 

·
Registered
Joined
·
2 Posts
I have tried to overclock this monitor and I'm not sure if I'm doing something wrong, if the test isn't good or I just shouldn't overclock it.

The thing is, I found out my monitor can go up to 81hz, which I find pretty good, but on the downside I tested the frameskip and it's rather noticeable. I tested it at 75, 70 and 65 hz and it still has got frameskip problems. I find it smoother, but on the other hand the frames that are missing makes it slightly stuttery, so I don't feel like I'm gaining anything.

I guess I'll stick to 60hz if no one has anything to advice.

Edit: I just read it's not OCeable, fair enough.
 

·
Registered
Joined
·
2 Posts
Hi guys,
I have this monitor, it's been working fine for some time but now I get "Entering Power Save Mode" and it goes blank.
I'm connected via DisplayPort cable, tried about 3 different ones. Same with all.
I tried a HDMI cable and only works to full HD resolution.
I can get it to light up on the DisplayPort cable but only on 1360x768 resolution, which is crappy.
Any ideas on how to make it work? Would I be able to go the full 2560x1440 resolution with a mini display port - DVI (dual link) cable?
I'm using a mid-2011 27" iMac.
Thanks.
 

·
Premium Member
Joined
·
16,114 Posts
Quote:
Originally Posted by petrum View Post

Hi guys,
I have this monitor, it's been working fine for some time but now I get "Entering Power Save Mode" and it goes blank.
I'm connected via DisplayPort cable, tried about 3 different ones. Same with all.
I tried a HDMI cable and only works to full HD resolution.
I can get it to light up on the DisplayPort cable but only on 1360x768 resolution, which is crappy.
Any ideas on how to make it work? Would I be able to go the full 2560x1440 resolution with a mini display port - DVI (dual link) cable?
I'm using a mid-2011 27" iMac.
Thanks.
Power source? And have you tested a different power cable to ensure it's nothing silly like that?
 
3061 - 3080 of 3080 Posts
Top