Overclock.net banner
1 - 20 of 2259 Posts

·
Registered
Joined
·
953 Posts
Discussion Starter · #1 ·
X370 XPOWER GAMING TITANIUM









Supports AMD® RYZEN Series processors and 7th Gen A-series / Athlon™ Processors for socket AM4

Supports DDR4-3200+(OC) Memory

DDR4 Boost with Steel Armor: Give your DDR4 memory a performance boost

VR Ready and VR Boost: Best virtual reality game experience without latency, reduces motion sickness

Mystic Light Extension and Mystic Light Sync: Control all LEDs in system with one click by GAMING APP or mobile devices

Turbo M.2 with M.2 Shield. Turbo U.2 with Steel Armor, Lightning USB 3.1 Gen2

Audio Boost 4 with Nahimic 2: Reward your ears with studio grade sound quality for the most immersive gaming experience

GAMING LAN with LAN Protect, powered by Intel® : The best online gaming experience with lowest latency and bandwidth management

BIOS Flashback+: Easy BIOS recovery without the need of a CPU, memory and VGA card

Military Class 5, Guard-Pro: Latest evolution in high quality components for best protection and efficiency

MULTI-GPU: With Steel Armor PCI-E slots. Supports NVIDIA SLI™ & AMD Crossfire™

In-Game Weapons: Game Boost, GAMING Hotkey, X-Boost, Xsplit Gamecaster

EZ Debug LED: Easiest way to troubleshoot

Click BIOS 5: Award-winning BIOS with high resolution scalable font, favorites and search function

GAMING CERTIFIED: 24-hour on and offline game and motherboard testing by eSports players

WHQL certified for Windows 10
 

·
Premium Member
Joined
·
10,252 Posts
Ordered one 15 minutes after they went on sale at newegg
smile.gif
 

·
Premium Member
Joined
·
10,252 Posts
Quote:
Originally Posted by Mikesamuel112 View Post

Mine is coming in next week Friday and I cant wait. Also got the G.Skill Trident 32GB at 3000Mhz.
I got the cl 14 trident Z's with the samsung ic's. Should be fun shaking these boards down , planning on having the 1800X under water - 480 mm radiator.
 

·
Premium Member
Joined
·
10,252 Posts
I;m hoping by the 10th dunno what they are planning on newegg's end.
 

·
Registered
Joined
·
571 Posts
Quick bad quality phone pic before throwing a system together.

This was a quick picture I took with my phone. Had limited time to get things together. The slightly better quality pic I had cut out the Digitalwolf paper... and yes my hand writing sucks.. no I'm not a doctor.

Currently I'm just running on the air cooler that comes with the 1700 (my loop is just hanging out lol). Going to order a new block soon(tm) so not really doing anything over clock wise at the moment.

I have a Z170 Titanium with the EK Monoblock (so I've always loved the looks)... it was a toss up between the CH6 and this. Came down to the fact I actually saw this in stock... my CH6 pre-orders never attempted to ship from any online retailer.

I saw EK had AM4 blocks on sale.. even shipping from them ends up being cheaper than buying it from my normal "in stock" source that charges crazy shipping prices. So I went ahead and ordered a block off the EK site.

Hopefully they eventually make a Monoblock for the X370 Titanium.
 

·
Registered
Joined
·
9 Posts
So, I've got the Ryzen system up and running last night using this board as a base for the platform.

The system is running;

R7 1700 [@4016.86 MHz]
16GB of Corsair RAM (2x8)
Samsung 960 Pro NVME as the main boot drive,
Corsair H110i
Corsair HX1050
CF 290x's

http://valid.x86.fr/59mu9y

Initial impressions? The board takes ages to boot --once it's up it seems to be totally fine, but man, it takes its time. Also, the RAM for whatever reason won't go past 2137--which is annoying. Setting XMP [2933] causes the machine to fail to post.

Still tweaking with some OC settings as what I have now is the quick and dirty but stable result. So far, my biggest complaint is the RAM issue. Hopefully it can be ironed out in the short term.
 

·
Registered
Joined
·
289 Posts
Quote:
Originally Posted by ngdot View Post

So, I've got the Ryzen system up and running last night using this board as a base for the platform.

The system is running;

R7 1700 [@4016.86 MHz]
16GB of Corsair RAM (2x8)
Samsung 960 Pro NVME as the main boot drive,
Corsair H110i
Corsair HX1050
CF 290x's

http://valid.x86.fr/59mu9y

Initial impressions? The board takes ages to boot --once it's up it seems to be totally fine, but man, it takes its time. Also, the RAM for whatever reason won't go past 2137--which is annoying. Setting XMP [2933] causes the machine to fail to post.

Still tweaking with some OC settings as what I have now is the quick and dirty but stable result. So far, my biggest complaint is the RAM issue. Hopefully it can be ironed out in the short term.
I know someone with this board and he had the same experience with the Samsung 960 Pro NVME drive, he changed it to another M.2 drive and boot time was fine. So it looks like either a bios compatibility issue with the device or Samsung need to update their firmware. Either way I'd send a ticket to MSI and let the know of that and also all RAM issue your experiencing.

On another point, it has been reported the PCI=E slot 2 with one graphics card installed is only running at 8x........can you confirm this????? If so then more reason to contact MSI and let them know this as well and push them for a bios fix.

I have this board and a 1700 sitting on the floor atm waiting to be set up, I'll do it later today and once things are up and running I'll let peeps know what issue I'm having........I plan on waiting a month or two to see how bios matures and how quick MSI can get fixes out and then I may buy the Asus Crosshair VI ROG if it proves to be the better offering.
 
  • Rep+
Reactions: Jackalito

·
Registered
Joined
·
571 Posts
I'm just running my 1700 @ 3700 until my block gets here.

For kicks this is my validation link:

http://valid.x86.fr/qjvc7q

For the boot time.. yes watching this Titanium boot is a good time to read a book. I am using the U.2 connector... I could use an adapter for M2_2 but that slot is x4 2.0 as opposed to the direct to cpu x4 3.0 of M2_1 or U.2.

So as the one reply suggests... if it's an issue with that slot I guess I'll just deal with it for now.

I'm running my ram @ 3200 without issue... I just used the timings suggested in one of the Asus CH6 threads and manually set everything. The only SS memory kit I had laying around was one of my older G.Skill kits that I have to use manual settings with anyway. (it's xmp frequency is well beyond anything Ryzen is doing atm).
 

·
Registered
Joined
·
2,732 Posts
Well i just ordered my titanium. Newegg says in stock through gigga. I will be modding my heatkiller to mount for now. Anyone have a clue how long until EK's monoblocks will be available? Site says they are coming but thats it so far. Anyone having the asus bricking issues so far? Or is the board pretty safe so far.
 

·
...
Joined
·
190 Posts
Hi all, I just bought the X370 Titanium at Microcenter ($259 last in stock!), and will pair it with a 1700. I was going to buy a 960 M.2 drive until I read the slow boot issues here. Can anyone confirm the boot is faster with other drives? How about with regular sata SSD? Or with an Intel 700 Pcie? I have an Intel 700 pcie from my other system that I may eventually transfer to the Ryzen build as well.
 
1 - 20 of 2259 Posts
Top