Overclock.net banner
1 - 3 of 3 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter · #1 ·
I've had a bit of a problem with my machine since a few days ago when windows update prompted me to install some new intel GFX drivers.

I don't use the onboard stuff, I've got 2 GTX670's and they were in there the first time the machine was booted. Originally I have never had anything listed in device manager under display adaptors other than my two 670's, even though I am pretty sure that I did install some Intel GFX drivers when I was initially setting up the machine and installing all kinds of updates etc.

The sequence of events in which things went wrong is hard to remember but I think it is as follows.

This became a problem when my "sleep" option was greyed out for no apparent reason. This appears to be because a "standard VGA graphics adapter" is now listed in device manager along with my 670's and the standard adapter had a conflict. Disabling this adapter allows the sleep function to be selected again.

I believe that I then tried to install these new drivers thinking that it would fix the conflict, the screen went black and then the problems started. The machine was still working however, judging by the core temperature visible on my MoBO which indicated activity.

My problem is two-fold.

If I leave the standard adapter disabled or select to uninstall it, windows update will constantly try to install the update to bring it to a newer version (this is with update set to it's default settings of installing important updates automatically.). This usually occurs upon waking from sleep or any time I boot. If it installs the update, I lose my picture, and the only way to get it back is to pull out both GFX cards. Boot using the onboard adapter. Uninstall all my nvidia drivers, stuff the GFX cards back in and install the drivers again. I've had to do this twice now and I'm pretty fed up with it.

My second option is to disable the adapter, and change the update settings so that it manually asks me for permission and what I want to install. This is a workaround though, as the onboard stuff isn't needed; shouldn't even be trying to update itself and to my mind should be disabled and not be in the device manager... as it was before it managed to update itself.

Is there any way to permanently disable it, get it out of my device manager, and set windows update back to it's automatic settings without it trying to update the on-board adapter all the time?

I'm not too pleased about having to change my settings to accommodate something that shouldn't even be there.
 

·
Registered
Joined
·
107 Posts
Discussion Starter · #2 ·
This computer is an utter mess now. After having failed to fix the problem, being forced to use system restore twice now in order to just be able to get back into desktop with the GFX cards installed, its utterly ****ed. Uninstallers aren't working, nvidia driver installers are failing as a long term solution it's unacceptable.

It's a complete wirte off and I'm going to have to wipe the entire ******* thing and start from scratch all because of a stupid update for something that isn't even used.

Anyone care to tell me how I do that?
 

·
Registered
Joined
·
575 Posts
Just noticed this post, hopefully it isn't too late!

In your BIOS, there is usually an option to enable / disable / auto integrated graphics. If you have a disable option, choose that. If you just have an auto option, that's fine too.

On my i5-3570k (with hd 7970), I know that I need to have drivers installed for the integrated graphics (even though I don't need them), otherwise weird stuff happens. A better option would be to let windows update what it wants, then go to Intel and get their official drivers for the integrated graphics. For me, that causes less issues between integrated / dedicated.

Also, what are the rest of your system specs?
And also, are your Nvidia drivers up to date?
 
1 - 3 of 3 Posts
Top