Overclock.net banner

1 - 16 of 16 Posts

·
Registered
Joined
·
607 Posts
Discussion Starter #1
I own a Wi-Fi repeater to which other smartphones and my wife's MacBook can connect to and have internet access. But on my Pixel 2, while I can connect to repeater wifi network I get the warning "connected, no internet access".

Does anyone know how I can fix this? Thanks In advance.
 

·
Registered
Joined
·
907 Posts
Remove the network through the wifi settings (forget) and then try readding to your list.
 

·
Registered
Joined
·
907 Posts
Because of the way pixels are built it could be having issues between your repeater and your main router. Make sure your router is set the id and Channel as your main router otherwise when it tries to use new repeater signal unhappiness can occur. Next, I would check that you do not have it set to a certain mode only. As your pixel is fairly new it shouldn't be a problem but make sure you have the repeater in mixed signal mode and note dedicated to one band such as N or Ac etc.
 

·
Registered
Joined
·
607 Posts
Discussion Starter #5
Because of the way pixels are built it could be having issues between your repeater and your main router. Make sure your router is set the id and Channel as your main router otherwise when it tries to use new repeater signal unhappiness can occur. Next, I would check that you do not have it set to a certain mode only. As your pixel is fairly new it shouldn't be a problem but make sure you have the repeater in mixed signal mode and note dedicated to one band such as N or Ac etc.
I tried both ways, with the same ssid and different one, dosent work. The channel is the same. I only have this issue with the Pixel 2, other smartphones or PCs work flawlessly.
 

·
Premium Member
Joined
·
6,664 Posts
The wifi repeater probably isnt passing on some information it should be. Other phones may be able to make do but there might be some security settings on the pixel 2 that make it unable to use internet without the required info for security reasons. Could look like a spoofed AP trying to do a man in the middle attack to the phone.
 

·
Registered
Joined
·
607 Posts
Discussion Starter #7
The wifi repeater probably isnt passing on some information it should be. Other phones may be able to make do but there might be some security settings on the pixel 2 that make it unable to use internet without the required info for security reasons. Could look like a spoofed AP trying to do a man in the middle attack to the phone.
I understand that but an iPhone is also very secure and it connects normally. It's disappointing to know that there's nothing to do to make it work, as it should.
 

·
Premium Member
Joined
·
6,664 Posts
Unless Apple has made significant changes lately, they actually do not conform to quite a few wifi specifications. Meanwhile Google has been doing quite a bit of pushing to greatly increase their security standards.
 

·
Registered
Joined
·
907 Posts
I am at a loss. Update the firmware on your router/repeater and please make sure that wps is not on and was not used in the setup. Manual config please.
 

·
Registered
Joined
·
607 Posts
Discussion Starter #10
I am at a loss. Update the firmware on your router/repeater and please make sure that wps is not on and was not used in the setup. Manual config please.
There is no firmware update available and WPS is not on. However, I´m having difficulty configuring it manually, can you please help?
Cheers
 

·
Registered
Joined
·
607 Posts
Discussion Starter #12
With my Nexus 6p and Pixel 2 I can't connect to the 5GHz WiFi on my router. The 2,4GHz band works without problems though.
That's a c
Shame, have you tried changing the channel on the router?
I'm my case I can't connect perfectly to the 5ghz band of my router. But I can't connect to the 2.4ghz only band from the repeater :(
 

·
Registered
Joined
·
607 Posts
Discussion Starter #14
That's a c
Shame, have you tried changing the channel on the router?
I'm my case I can't connect perfectly to the 5ghz band of my router. But I can't connect to the 2.4ghz only band from the repeater :(
Yes but I am at a village so there's no channels taken in the neighborhood. And the router dosent have 5ghz band, only 2.4ghz. I am at a loss.
 

·
Registered
Joined
·
907 Posts
1 - 16 of 16 Posts
Top