Overclock.net banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2,135 Posts
Discussion Starter #1
Hello


I'm using Win7 x64 at the moment and wanted to install Ubuntu 10.04 x64 in 2nd partition in the same drive. But everytime I tried booting from the disk, I kept getting 'Unable to find live media ....' error. After some searching in Google, I came across posts which said this is because the DVD drive is having issues. So I moved my DVD drive from SATA port 2 to 5 (mobo manual says 1-4 for hdds and 5-6 for optical drives). This time, I can boot from the disk without the above error. But, after the purple screen with the text Ubuntu in White + 5 red/White dots, I'm getting a blank screen. And then my monitor shuts off because it isn't getting any signal.

So, to avoid anything unwanted happening to my Win7 installation, I have decided to install Ubuntu into a 2nd hdd and select between them in BIOS as needed. So I disconnected (temporarily) the Win7 hdd and tried booting from Ubuntu disk again, but I'm still getting blank screen.

I also tried the application which can use an Ubuntu image to make a bootable USB stick. But my mobo just ignores it for some reason, even though I've set Removable Devices as 1st boot device. The USB stick is being recognised though, as the POST screen says Intenso Lite Highspeed Device.

So what do I do now? Any help will be very much appreciated!
And sorry about the long post ..
 

·
Premium Member
Joined
·
4,521 Posts
this is a common problem with 10.04, grab the alternate install cd.

which program are you using to make the liveusb?

i would suggest using unetbootin.

http://www.ubuntu.com/desktop/get-ub...ative-download

here is the link to the alternate install cd.

whatever you do, do not use WUBI
 

·
Registered
Joined
·
2,135 Posts
Discussion Starter #3
Quote:

Originally Posted by transhour View Post
this is a common problem with 10.04, grab the alternate install cd.

which program are you using to make the liveusb?

i would suggest using unetbootin.

http://www.ubuntu.com/desktop/get-ub...ative-download

here is the link to the alternate install cd.

whatever you do, do not use WUBI

Thanks for the quick reply, much appreciated!
I was using Unetbootin for the bootable USB. And I also tried WUBI installer to do it within Windows, but that gave me a blank screen as well! Trying an alternate 64bit version now ..
 

·
Registered
Joined
·
2,135 Posts
Discussion Starter #4
An update, I used the alternate x64 cd as recommended by transhour. The installation went without any glitches, but I'm still getting a blank screen after the purple Ubuntu + 5 dots screen. So I tried starting up with recovery mode and then selected fail-safe graphics mode, and it started up with any issues. So I guess my GPUs are somehow affecting Ubuntu?
I've got 2 HD 5770s in CrossFire ..

EDIT: It's all good now. Ubuntu gave me an update from AMD/ATi and no more blank screens! Cheers for the help!
 

·
Premium Member
Joined
·
4,521 Posts
yeah linux ships with what they call "open source" drivers, which are just horrible little things right now, they don't like graphics cards that much, and they really don't like cross fire and they absolutely hate sli.

you can get them both working usually without problem once you install the prop drivers, just a bit of work around to get it installed and to the point where you can install prop drivers for it


i'm glad you got your problems solved
 

·
Premium Member
Joined
·
4,521 Posts
open up terminal, type in this command,

sudo apt-get install gparted

if it ask you any questions answer yes, let it install.

then go to system->administration->gpart

resize the partition you want for swap or create it on another drive, once you are done there, let us know we will tell you how to activate it and mount it


edit: i'm about to go to bed, sorry for the brief response, if you can not figure out how to use gparted, if you can wait a bit, i can explain in detail how to do all this or maybe one of the other linux guru's will be kind enough to beat me to it
 

·
Premium Member
Joined
·
4,521 Posts
alright i am home from my sunday routine, i didn't forget about you jcg, just didn't have time this morning to write up a guide


i am working on it now, it will be done in a bit


later
 

·
Premium Member
Joined
·
4,521 Posts
First thing you want to do is decide how big you want a swap partition to be, unlike windows, linux the more ram you have, the less swap you need.

If you have more than 2 GB's of ram I would honestly say all you would need is a 512 MB of swap space, maybe 1 GB to be a bit more comfortable, especially in ubuntu 10.04, the “prefetch†they use, I think it is called ureadahead is kind stupid, and doesn't always release cached programs and the kernel will be forced to use the swap, this is a rare thing, but it has happened to me since using 10.04.

if you have less than 2 GB's of ram, I would suggest 1/1 ratio at least, maybe a 2/1 ratio if you only have a 1 gb of ram.

Okay once you decide how large you want your swap partition, you will need to decide which harddrive you want it to be on.

Open up a terminal and type in the following command:

sudo gparted&

it will ask for your password, enter it, it will then start up gparted, a disk utility, with full root privilages which you will need to make any alterations to a partition.

It will take a few moments to scan the bus, and detect which harddrives you have hooked up and what partitons they have on them.

In the right hand corner, is a drop down, that will have all your drives in it, locate the drive you want to add the swap partition too.

/dev/sda = first harddrive
/dev/sdb = second harddrive
etc.

once you choose the harddrive, find which partition you wish to resize. If it is mounted, right click on it and choose “unmountâ€, I should note here, if this root partition to the linux installation, you will need to do this from a livecd/usb.

Once the drive is unmounted, right click on in and choose “resize/moveâ€. In the new window that pops up you will have 3 options how to allocate the space.

Free space preceding (MIB)
new size (Mib)
free space following (MIB)

also at the top, you will have a slider of sorts with black arrows at the end of it. You can use this as well to reallocate the space. It doesn't really matter if you allocate the space for the new partition before or after the existing partition, it will work the same imho, others might disagree with me tho


once the space is reallocated, click resize/move.

Now you will notice that it has unallocated space in the gparted area, right click on it and choose “newâ€

in this new window, look for “file system†and choose linux-swap, then click add.

If everything looks good, then you are set, click on the green check mark in toolbar, and you are set, depending on the size of the drive, it will take a bit to resize and create the new swap.

Once it is done, find the new swap partition, right click on and activate it.

Now return to the terminal, you might have to hit enter, but the cli will return.

Type this command in:

blkid

Quote:
/dev/sda1: LABEL="System Reserved" UUID="74B03141B0310B5E" TYPE="ntfs"
/dev/sda2: UUID="4830357830356E56" TYPE="ntfs"
/dev/sda3: UUID="13bd79d1-bc5d-4352-b9d8-a6b51e361b65" TYPE="swap"
/dev/sda5: UUID="98b74a2e-64eb-49a3-9fb0-b044f446dcc4" TYPE="ext2"
/dev/sda6: UUID="b95c92f7-5343-48d9-955e-5f9e3e5e81a1" TYPE="ext4"
/dev/sda7: UUID="1c6beec1-8b35-4b35-aa10-a4baa2006ca1" TYPE="ext4"
/dev/sdb1: UUID="bce8ca48-4d95-4a3f-bacc-4a370e30dbf0" TYPE="ext4"
/dev/sdc1: LABEL="Drive One" UUID="61B9CA0733C96ED5" TYPE="ntfs"
the output will look something like this. Look for the one thats TYPE=â€swapâ€, copy the UUID it, it is the number in red. (do not use the uuid from this example as it is the one for my device
)

Now type in:

nano /etc/fstab

at the end of the fstab, put this

UUID=13bd79d1-bc5d-4352-b9d8-a6b51e361b65 none swap sw 0 0

replace the numbers in red with your UUID, hit ctrl+o, it saves the file, ctrl+x exits out of nano. Now everytime you reboot, the swap should be automounted
.

any questions just ask
 

·
Registered
Joined
·
2,135 Posts
Discussion Starter #10
Thanks for the taking the time to do this, transhour; +rep to you!


I was having trouble setting it up myself; I just couldn't get the partitions right! It was then I found out it was probably because I had 4 primary partitions in one hard drive. So I then backed up 2 partitions and then set them as logical. While working on the partitions, I must've changed the order or something, because I messed up GRUB/MBR and lost both Windows and Ubuntu!
Wasn't a big issue though since both were new installations. So I re-installed Ubuntu (& Win7) again and set up swap space for 5GB during the installation process itself. Everything's running alright now!


Thanks again for the guide, and sorry for putting you through the trouble of making it ..

Quote:

Originally Posted by transhour View Post
open up terminal, type in this command,

sudo apt-get install gparted

if it ask you any questions answer yes, let it install.

then go to system->administration->gpart
+rep for this bit as well.
 
1 - 10 of 10 Posts
Top