Overclock.net banner

Please help! Why is my new card running so slow!

651 Views 15 Replies 11 Participants Last post by  chopsuix
Here's the situation. I have this desktop which is about 6 years old and had it all through university. It was great at the time and could run, farcry, CS source and a bunch of games at high quality. Here are the basic specs of the original system

CPU: AMD Athlon 64 3400+
Ram: 2 gigs
Graphics: ATI radeon 800XL AGP 256mb
HD: 150gb

A few months ago, my video card died, so I decided to go on newegg and buy a new one. My mentality was that if my original card cost me $250 6 years ago, i should be able to get something just as good or better for $75. I decided to go with the

EVGA GeForce 6200 256DDR2.

The card came I popped it in and once all the drivers were installed i booted up CS source and it was unplayable. I had to turn all the settings down to low/medium to get the fps up. What gives? Shouldn't the GeForce be able to handle the same types of games as my original radeon? I'm not looking to build/buy a new system I just wanted to replace the video card. Can anyone suggest a better card for under $100?
1 - 1 of 1 Posts

· Registered
Joined
·
558 Posts
The 6200 is MUCH weaker than the one you had. Not sure why you got it before consulting it if it was good or not.

If you can, try to return it or get a new one like this http://www.newegg.com/Product/Produc...82E16814125281 Which is around 80 dollars and just as good as your ol' 800 XL.

Would have suggested the 4670 but its 130.

you can also try to find people selling good old AGP cards.
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top