Overclock.net banner

1 - 4 of 4 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
Hello,

I have an ultra 500 watt power supply. The fan spins up inside the unit when it's running with the paperclip trick (not plugged into motherboard) but then shuts down as soon as a hook anything that puts a load on it, even an external fan. I suspect the power supply is bad but I blew up my multimeter testing a power another power supply (still learning). Anyway, does it sound like the power supply? Do you think I should buy a multimeter and check the power supply before I chuck it?
 

·
Banned
Joined
·
1,910 Posts
Quote:


Originally Posted by angrysquirrel
View Post

Hello,

I have an ultra 500 watt power supply. The fan spins up inside the unit when it's running with the paperclip trick (not plugged into motherboard) but then shuts down as soon as a hook anything that puts a load on it, even an external fan. I suspect the power supply is bad but I blew up my multimeter testing a power another power supply (still learning). Anyway, does it sound like the power supply? Do you think I should buy a multimeter and check the power supply before I chuck it?

try using the paperclip trick and powering some fans up... also try using it as an exertnal hard drive for a relatively beefy card like an 8800gtx alone. if it will handle that then it is your mobo, if not then the PSU is bad...it is a mid-low end psu ne way
 

·
Registered
Joined
·
29 Posts
Discussion Starter #3
Thanks! Looks like the thing is dead. I can't even power a small fan without the power supply shutting down. I gotta learn more about this electricity stuff.
 

·
Premium Member
Joined
·
65,162 Posts
Have you tried more than one fan? It could be a shorted fan.
 
1 - 4 of 4 Posts
Top