Overclock.net banner
1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
SPECS:
Intel Quad Core i7-2600k 3.40 GHz 8mb L3 Cache
Gigabyte GA-Z77-D3H
Cooler Master Silent Pro M 850w
DDR3 8GB 1600MHz
Win7 64bit
ADATA SSD 120gb + (250 + 150gb HDDs)
Geforce GTS 250 + XFX AMD Radeon HD7970

Upon removing my previous graphic card, a Geforce GTS 250, I proceeded to upgrade my PSU and bringing my computer to the specifications I listed above, then proceeded to install the Radeon 7970 graphics card. Testing the new hardware resulted in a black screen, after 4 hours of tedious tinkering and deletion of old drivers, I managed to use the on-board graphics to download drivers individually and somehow it ended up working, somehow....

The graphics card worked for two days just fine, I tested it on borderlands 2, team fortress 2, and deus ex: human revolution, I did shut down the computer numerous time so it was not two days continuously however. While simply browsing the web on the third day my screen suddenly went black and since then has not recovered no matter how long I leave the computer off for, how much time I wait or what I try. I am at wit`s end and have no clue what to do next, I put my old graphic card back in and everything worked just fine. I checked the bios version and it seems the only higher version of the bios available for my motherboard is 19g instead of 18, and 19g is labeled as a "Beta" version in testing, I doubt the bios is the problem but if other people say otherwise then I might try it.

I did reset my bios to factory defaults or CMOS or whatever it's called, did make sure that it was reading from the pci slot as well again. I tried moving cables around into different slots because it is a modular power supply, but those cables worked just fine for my GTS so. I also tried using an hdmi(vga) to dvi(monitor) cable and dvi(vga) to dvi(monitor) cable to see if that was the problem, but the HDMI to DVI worked just fine till it died before so....

I sent a support ticket to XFX, but I haven't a clue when I'm going to get a response.

The card was bought from Tiger Direct the actual, physical retail store. Walked in looking for a 7870 by HIS which they didn't have and bought the XFX 7970 since it was the best model they did have.

Thanks in advance to any and all help offered. If I can't figure this out soon I'll have to RMA it.
 

·
Registered
Joined
·
1,559 Posts
Sounds like you may want exchange the card for another one, if a second card does the same thing than you know it's the pc. But to me it sounds like a gpu problem, since the old card works fine.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
A friend who's better than me when it comes to computers did recommend that I go back to the store and ask for a second, bring the whole PC there to test it on-site. I DO feel like I've done everything except update the bios. The store will be closed by the time I drive there so I will have to go tomorrow unfortunately. Funny how I was browsing steam looking for games to test these new graphics on and they fail on me. =/
 

·
Premium Member
Joined
·
17,407 Posts
What drivers are you using? I had issues with my 7770 in my HTPC with constant black screens (but the PC continued to work, I could hear audio). It seems it was an issue with many of the 7000 series. After updating to new 13.1 drivers, I finally stopped getting black screens.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Quote:
Latest Beta Driver 187 MB 13.2 Beta 2/18/2013
Description:
Download our latest beta driver and get a preview of what we're currently working on.
Note! This driver is provided "AS IS" and under the terms and conditions of the End User License Agreement provided therewithin.
Please note that the Catalyst Control Center component of the AMD Catalyst 13.2 Beta requires .NET 4.0 support for Windows Vista and Windows 7 users.
AMD Catalyst Control Center requires Microsoft .NET4 Framework. Windows Vista and Windows 7 users may need to install the Microsoft .NET4 Framework as a prerequisite to use Catalyst Control Center.
directly from the official AMD website, it was one of the three choices, the first one didn't work, last one isn't a driver, this seemed like a driver so I got this one. Didn't see any other ones so....
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
deleted all drivers and downloaded a 13.1 however I can't install the drivers without the graphic card in there already, putting it in there doesn't work so I can't really navigate with nothing but sound. I might have to use both the GTS and 7970 at the same time but I haven't a clue if it will work.
 

·
Premium Member
Joined
·
17,407 Posts
Quote:
Originally Posted by ShimonoRyouta View Post

deleted all drivers and downloaded a 13.1 however I can't install the drivers without the graphic card in there already, putting it in there doesn't work so I can't really navigate with nothing but sound. I might have to use both the GTS and 7970 at the same time but I haven't a clue if it will work.
It shouldn't be that difficult to install. The card should still show up with no drivers installed. Have you tried a fresh OS install?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
I haven't done a fresh install no, my computer is currently missing a CD/DVD drive and I installed windows 7 using a friend's usb external DVD drive. SO can't really do a fresh OS install but I'll leave that for last, there's a LOT of things I'd need to back up before I do that and no patience for it all right now...

Computer was lacking enough power to do 2 graphic cards at once it seems, tried to work with nvidia and amd at the same time... well anyway back to square 1
 
1 - 8 of 8 Posts
Top