Overclock.net banner
1 - 20 of 51 Posts

·
Registered
Joined
·
1,605 Posts
Discussion Starter · #1 ·
new antec 620 is making that hrd drive noise as soon as i first started it before putting ram and card to test it. I left it for 10 or so minutes and its still like that. Its more than audible and really annoying, it also sounds like electrical or static sound. Like very fast clicking and when i shake the rad it creates a toilet flush sound from the pump. is this normal?

edit: my installation went as follows, i attached the pump to the metal mounting ring using another plastic ring that was in the box, so basically the metal ring with the thumbscrews and the pump became one piece that i then pushed and screwed onto the mobo. Thats how it was in the manual. like you would with a stock cooler except here its with screws. The weird part is that since the screws were attached to the pump i had to screw each screw so it can gradually lower the whole thing to meet the cpu instead of the usual way which is to instantly place the pump on the cpu for the paste to spread evenly. Also the antec logo is upside down, i may have made the tubes upside down i dont think about this until now, i just assumed it would be counterproductive to block the top fan with the tubes but now im thinking its bad for the tubes to rest on the gpu.
 

·
Registered
Joined
·
1,605 Posts
Discussion Starter · #3 ·
Quote:
Originally Posted by gzboli View Post

Probably many small air bubbles flowing through the loop. Give it more time and see if the sound lessens.
you recommend i do that with seeing cpu temp? as i dont have ram or gpu installed yet nor a monitor. I tried the power to fan controller and just messing around. the thing is i used a pump like it before and it made no sound whatsoever, was silent unless you had your ear to it. this one seems faulty to me.
 

·
Registered
Joined
·
1,605 Posts
Discussion Starter · #4 ·
i just noticed that the rubber fitting thing on the rad end of one tube can be rotated, is that normal?



edit: been going for 20 minutes, still loud grinding and static hum.
 

·
Registered
Joined
·
1,605 Posts
Discussion Starter · #7 ·
Quote:
Originally Posted by jjpctech View Post

RMA it mate
i would if i was sure i wont experience the same thing with another pump. just googlying shows me corsair's h80 had a patch where it was all grinding noise that sometimes went away on it own after use. not much shows up for Antec, that could either mean its rare or not many bought the product. im thinking to just return it and use stock cooler.
 

·
TotallydubbedHD on YT
Joined
·
11,564 Posts
As I said - usually air bubbles - if that shaking doesn't solve it, then you ought to return it.
Shouldn't last more than 5-1mins usually.

Sounds like you got either a bad pump or a dry unit.
 

·
Registered
Joined
·
1,605 Posts
Discussion Starter · #10 ·
does a dry unit cool the CPU adequately? I ask because I never actually seen CPU temps as it worked because monitor didn't arrive yet.
 

·
TotallydubbedHD on YT
Joined
·
11,564 Posts
Quote:
Originally Posted by dioxholster View Post

does a dry unit cool the CPU adequately? I ask because I never actually seen CPU temps as it worked because monitor didn't arrive yet.
You should probably wait until you have your whole setup...
 

·
TotallydubbedHD on YT
Joined
·
11,564 Posts
Quote:
Originally Posted by dioxholster View Post

I don't have time for that.
You don't have time for a monitor, and expect the antec to work normally?
You do realize that you need to use the software/bios in order to actually make the antec pump work optimally?

That's like saying - I built a car without wheels and I don't have time to check the engine fluid.

Anyway - you have my thoughts - good luck
wink.gif
 

·
Registered
Joined
·
1,605 Posts
Discussion Starter · #14 ·
I've had that cooler before so I know how it's supposed to behave. I plugged it to PSU so bios would not help. I used fan controller it sounds bad at all levels. now can I use tv or laptop to view bios?
 

·
TotallydubbedHD on YT
Joined
·
11,564 Posts
Quote:
Originally Posted by dioxholster View Post

I've had that cooler before so I know how it's supposed to behave. I plugged it to PSU so bios would not help. I used fan controller it sounds bad at all levels. now can I use tv or laptop to view bios?
Of course you can - use a TV.
But if you've tried everything - I stand by what I said before - send it back.

It is just crazy to let it run (especially if the pump isn't working) without knowing what your actual CPU temps are!
In other words - don't fry your chip due to a $50 antec 620.
 

·
Registered
Joined
·
1,605 Posts
Discussion Starter · #16 ·
I thought since it's making bubble noise then it must be working. usually pumps work never read complaints that say otherwise it's noise thats usually the issue or leaks. tv how about laptop? and of course I need graphics card? and ram?
 

·
Registered
Joined
·
339 Posts
Quote:
Originally Posted by dioxholster View Post

I don't have time for that.
Things are critical man, no time for due process.
 

·
TotallydubbedHD on YT
Joined
·
11,564 Posts
Quote:
Originally Posted by dioxholster View Post

I thought since it's making bubble noise then it must be working. usually pumps work never read complaints that say otherwise it's noise thats usually the issue or leaks. tv how about laptop? and of course I need graphics card? and ram?
Do you have anything in your PC apart from a motherboard CPU and cooler?
I don't quite get this...

You are potentially risking your chip from being burnt - that's all I'm saying.
But hey, your PC
thumb.gif
 

·
Registered
Joined
·
1,605 Posts
Discussion Starter · #19 ·
Quote:
Originally Posted by CallAMedic4U View Post

Things are critical man, no time for due process.
dont know what you mean but cleaning grease off CPU takes me whole day if I dont do it now I will never be able to in coming weeks. and laptop I depended on died on me so I really need it.
 

·
Registered
Joined
·
1,605 Posts
Discussion Starter · #20 ·
Quote:
Originally Posted by Totally Dubbed View Post

Do you have anything in your PC apart from a motherboard CPU and cooler?
I don't quite get this...

You are potentially risking your chip from being burnt - that's all I'm saying.
But hey, your PC
thumb.gif
didn't see point in installing the rest since there is no screen. what's the risk here other than cooler might not be working? I will check to see if it was working or not before replacing it.
 
1 - 20 of 51 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top