Overclock.net banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1,810 Posts
Discussion Starter · #1 ·
Hello, i just bought my second deathadder mouse this year, and the mouse is having the same problem as my first one bought in january 2011.

The scroll wheel isn't well fixed on that axis, it's sliding a little on the left and right, and is kinda noisy when i scroll up, basically it has the same problem that my old deathadder.

Well, what the heck is it ? I just spend money on another broken deathadder, it is a mass fail, or that scroll wheel is meant to be like that, not well fixed, or that is the model or what ? Anyone has the same problem.

Note: The mouse is brand new, today has arrived to me.

And the sensor is heating a little, even if the mouse is on idle.
 

·
Registered
Joined
·
489 Posts
If the scroll wheel squeaks, get an oil pen and put a drop on the sides. If its something else just RMA it. The scroll wheel on the black version I had worked fine. I am not sure about this "heating" problem you are having.
 

·
Registered
Joined
·
573 Posts
A small amount of wobble is unavoidable due to the way the wheel is "held" in place. I have one in bits right now and the mounting mechanism is rather poor compared to other mice I've opened.
 

·
Registered
Joined
·
1,653 Posts
Quote:
Originally Posted by calin05;14222273
So i assume that nobody has this problems, only me ?
I had it on another mouse, which uses the same mechanism.
Maybe it is even wanted from razer, to make the mouse3 click lighter.
you could fix it with double-sided tape which u stick some bit at the end of the scrollwheel to make that part thicker, making it sit firmer in the hole of the scrollwheel encoder.
 

·
Registered
Joined
·
1,460 Posts
Quote:
Originally Posted by calin05;14214789
Hello, i just bought my second deathadder mouse this year, and the mouse is having the same problem as my first one bought in january 2011.

The scroll wheel isn't well fixed on that axis, it's sliding a little on the left and right, and is kinda noisy when i scroll up, basically it has the same problem that my old deathadder.

Well, what the heck is it ? I just spend money on another broken deathadder, it is a mass fail, or that scroll wheel is meant to be like that, not well fixed, or that is the model or what ? Anyone has the same problem.

Note: The mouse is brand new, today has arrived to me.

And the sensor is heating a little, even if the mouse is on idle.
So I just got my DeathAdder today and am now noticing your problem. My scroll wheel does wobble just a tiny bit but it doesn't bother me. What does bother me is that when I scroll forward it feels like I'm scrolling through sandpaper and it's a fair bit louder as opposed to when I scroll in reverse it's much smoother and much quieter. Will some oil fix this?
 
1 - 6 of 6 Posts
Top