Overclock.net banner

1 - 20 of 33 Posts

·
Registered
Joined
·
2,397 Posts
Discussion Starter #1
this is what i get if i try and play rollercoaster tycoon 2 on windows 7 32 oR 64 bit ( gtx480)

you can hear the game working and the screen moving in places but you cant stop it doing that, compatibility mode makes no difference to it..it DOES work in xp 32bbit...( im sure i had this working in win7 32 at one point but thats when i had a gtx285 )

i have not seen a game were it does that to the screen yet.

do you people have any idea how i can get this to work....or is this just one of them games that screwed up on win 7

]
 

·
Registered
Joined
·
505 Posts
its not win7, set your desktop res to 1280x1024 or lower, then open it again
 

·
Registered
Joined
·
2,397 Posts
Discussion Starter #3
Quote:

Originally Posted by !ender_ View Post
its not win7, set your desktop res to 1280x1024 or lower, then open it again
yes i did that and it made no diff as what so ever.
 

·
Registered
Joined
·
5 Posts
I have searched all over the net for someone with the same problem and then I've found this so I registered here. I get the same problem when running rct2 on windows 7 x64 on my gtx 480.

I have tried every single compability mode and all other compability options and none have worked. Setting the color depht to 256 colors from the screen resolution panel didn't work either.

I really want to play this classic game so I hope we can figure out a solution together.
 

·
Custom User Title
Joined
·
3,652 Posts
Does it have a run in windows option?

I think you can set that via Nv control panel.
 

·
Registered
Joined
·
5 Posts
Not what I could find. I tried add -window to the target box in the shortcut properties and it still played in fullscreen.
 

·
Registered
Joined
·
2,397 Posts
Discussion Starter #8
I think I can say with the gtx480 were going to have to play it in xp.

im still no closer to fixing it. had to put xp on one of my ssds and played it that way..dual boot. so yes.
 

·
Registered
Joined
·
1 Posts
Hey Nigel, My gf plays this game and having the same troubles, just upgraded from a GTS250 to a GTX480 running win7 64 and getting troubles as you are. everything was fine until i put the 480 in. Im thinking its a driver issue or some kind of compatibilty isue with the GTX480, did you manage to find a fix for it? will post back if i can work out what the trouble is.
 

·
New to OCN? Yeah, nah
Joined
·
4,231 Posts
Wait a second. Try this.

Before you start the game, go into your task manager and kill explorer.exe

It works for Starcraft, so it may work for this.
 

·
Premium Member
Joined
·
18,210 Posts
Funny enugh i played this a week ago on my 5870 and it worked fine i couldnt stand the low end graphics on it tho so i removed it.
 

·
Registered
Joined
·
5 Posts
Quote:

Originally Posted by aroc91 View Post
Wait a second. Try this.

Before you start the game, go into your task manager and kill explorer.exe

It works for Starcraft, so it may work for this.
Didn't help =/
 

·
Registered
Joined
·
2,397 Posts
Discussion Starter #14
yes looks like its just going to be one of them things.....like sead before your going to have to xp on a spare hdd and play it that way.
 

·
Premium Member
Joined
·
4,083 Posts
Quote:

Originally Posted by aroc91 View Post
Wait a second. Try this.

Before you start the game, go into your task manager and kill explorer.exe

It works for Starcraft, so it may work for this.
this works for many games for me, especially age of empires. shame it didnt for you.

anyhoo, you MIGHT wanna try selecting different compat modes. dunno if you have, or havent yet.

anotheridea, windows xp mode - http://www.microsoft.com/windows/vir.../download.aspx
 

·
Registered
Joined
·
5 Posts
Quote:

Originally Posted by Greensystemsgo View Post
this works for many games for me, especially age of empires. shame it didnt for you.

anyhoo, you MIGHT wanna try selecting different compat modes. dunno if you have, or havent yet.

anotheridea, windows xp mode - http://www.microsoft.com/windows/vir.../download.aspx
All compability modes tested without luck.

The emulated graphics card inside windows virtual pc xp mode don't have support for rollercoaster.
 

·
Super Moderator
Joined
·
32,931 Posts
One thing you can try, even though its a royal pain.....

Install XP into a virtual machine. I know it'll suck to have to boot a virtual machine to play it, but this way you don't have to dual boot.

It works 100% perfectly fine on my machine. Windows 7 x64, and a HD4850. So it's GOT to be a driver issue (HA! ATI isn't the only one with driver issues
).
 

·
Registered
Joined
·
480 Posts
I finally figured this out, its dumb and backwards and a last resort, but it worked.

I had a friend load rct2 on his laptop (running xp) and had him start a game and show me where the change resolution button is.

so then I booted rct2 on my computer (win7 64bit) it was doing the same old squigly lines thing. you can kind of guess where stuff is and hit new game then click a scenario without being able to see

so once I was in a new game I went up to the floppy disk key (you can tell it is the second button over, then go down four menu items one of them didnt ligt up blue for me. then I kind of randomly clicked on the left side of the screen where the box was until I hit the change resolution option, now everything works!

Ill try and upload pics to help if I can.
 

·
Registered
Joined
·
1,644 Posts
ive got win 7 64 bit, so i installed it to see if i could help. i was able to play it fine, no lines or distortions at all. im thinkin its a driver issue...

/edit

also, my native res is 1920x1080. rct2 automatically reverts to 800x600 (or something like that) when i play
 
1 - 20 of 33 Posts
Top