Overclock.net banner
1 - 20 of 29 Posts

·
Registered
Joined
·
709 Posts
Discussion Starter · #1 ·
WHATS UP OCN?

after many days of fooling around with this game i managed to fix everything..
even my 4870 1 gb card can max this now..

in the beginning i had this at 1280x800 with mixed settings at best with garbage game play and massive lag...not to mention it looked horrible..

now i run it maxed out on 1920x1080 silky smooth no jagged edges nothing!!!

i tested these settings over and over on Miami track...which was a lag fest....

anyway

there is some issue with ea's code in how they set up all the graphics..

because when i turn aa of in the settings of the game its like maxed out?

this is how it is for most people...

what you need to do with any ati card, to fix low fps, lag, stuttering issues is this..

get the new 11.3 drivers...

SmoothVision HD Anti Aliasing =

choose 4x first
then choose edge detect in the drop down box
then use the check box to use app settings, check it enabled!

SmoothVision HD Anisotropic filtering =

use the check box to use app settings, check it enabled!

Tessellation=

use the check box to use app settings, check it enabled!

Catalyst AI=

high quality, again this is user pref, maybe your card needs it lowerd,

Code:

Code:
do not use the check box to use enable surface format optimization, this causes the black and white issues in the car!
Mini Map Detail Level=

High quality, again this is user pref, maybe your card needs it lowered,

Wait for vertical refresh =

off

Anti Aliasing mode=

super sample aa, again this is user pref, maybe your card needs it lowered,

Open gl settings=

Triple Buffering Checkbox is to be checked...

Code:

Code:
test these settings with this specific in game settings as well for 100% optimal performance and 100% amazing visuals
Resolutuion -1920x1080 <-if you have 20in or less moniter use 1280x1024
Window Mode -no <- you can enable this if you wana do window mode
Texture Resolution -high
Texture Filtering -high
V-sync -no <- this is a most causes about 20 to 30 fps loss enabled
Anti Alising -off <- dont worry no jaggys i promise just try the setting
Motion Blur -off <- seems like a ******ed feature so i disabled it
Refelection Quality -high
Car Detail -high
Track Detail -high
Shadown Detail - low <-i like this on low it dosent matter if its not high

Please dont just close the page after reading aa is disabled in this post..
honestly its not disabled, visually its not, and there is zero jagged edges...
please do the right thing and test these settings exctaly with your ati card!!, you wont regret it...this is how the game is ment to be played!!
 

·
Registered
Joined
·
1 Posts
Im seriously blown away by this fix, I had to register just to thank you.

I have a new system sandy bridge 2500k @ 4.5 Ghz and a 5850 and was pretty bummed out that the game was running so average where Crysis 2 runs like a dream. Anyway FPS from 49 to 84. Thanks again. i'll post this fix and point to this forum.
 

·
Banned
Joined
·
4,294 Posts
Too bad 11.x drivers causes an amazing thing!

99% Load on GPU in idle, on my 5850, any previous driver works fine, and Ive read about this on the AMD forum and elsewhere. Its not something I want to do again.
The only positive thing about them is that the color /saturation now functions as proper rather than turning your monitor pink.

Anyhow, I play the game just fine in 1920x1200 all on High with AA off (it causes a weird white line on night maps surrounding some stuff) and Ive also noticed a graphical glitch concerning trees, think its related to antialiasing, but you notice them the most at night. You see a constant "box" of white lines and **** in the trees.

Otherwise, nice find.
 

·
Registered
Joined
·
1 Posts
Legittt I just registered to say this works perfectly, I did exactly what he said and it runs without a dropped frame now. He is right about the shadows too, they look even better on low... specs : phenom x4 9550 slight oc, his 5670 1gb stock, 4gb ddr2 800mhz slight oc.
 

·
Registered
Joined
·
1,878 Posts
I'm getting constant 60+, Boy is this game amazing, feels nothing like the original shift.
 

·
Registered
Joined
·
9 Posts
I tried this and no AA is visble on the cars or anything else that comes into focus. However the shadows are very much improved and lag / stutters are gone.

Are you guys sure you have AA even though this essentially disables it? I'd like to get this working if possible. I have a good system, but I'm running three screens and the game does lag on certain tracks with AA.
 

·
Registered
Joined
·
594 Posts
WOW! When I first played this game on my rig it was not even playable. I was getting around 20-25fps and it lagged like a SOB, so I stopped playing after the first race! After using the settings you posted, I'm now running around 40-60 all the time,Tho I can see some major jaggies, but I also forgot to set the texture filtering in-game to high (was on Trilinear) 2 races later and all is good! Thanks for making this playable!

UPDATE: I turned on texture filtering on high,but then i get lag, I can see jaggies everywhere,looks like EA has some patching to do.....
 

·
Registered
Joined
·
1 Posts
Thanks for the info and setups. This has made the game 100% more enjoyable and fixed all the bugs. Not being a young nimble gamer I need all the help I can get. Thanks
 

·
Music Producer
Joined
·
4,860 Posts
Quote:
Originally Posted by FLCLimax;12971347
never had this issue, and i get pretty high frames.
this, but then again im running nVidia so im not sure if there was a performance issue for both ATi and nVidia.
 

·
Registered
Joined
·
279 Posts
Never had any problem neither using an HD5770 and 11.4 Preview drivers. Running 45 FPS at 1280x1024 with everything maxed out minus Morphological Filtering which made the game look kind of cartoonish to me.
 

·
Registered
Joined
·
1 Posts
Me to
this fixed my problem whit the game.
i still can get a lillt lag but i can live whit that.

running a quardcore 2.6 4gram 6850 ati

Quote:
Originally Posted by Cash;12952722
Im seriously blown away by this fix, I had to register just to thank you.

I have a new system sandy bridge 2500k @ 4.5 Ghz and a 5850 and was pretty bummed out that the game was running so average where Crysis 2 runs like a dream. Anyway FPS from 49 to 84. Thanks again. i'll post this fix and point to this forum.
thumbsupsmiley.png
:thumbsups:thumbsups:thumbsups
 

·
Registered
Joined
·
1 Posts
I too just registered to respond. lol

Anyways, by far this is the best fix I've seen yet. I'm Running the following specs:
  • 2 ATI Radeon HD4850 512 in Crossfire
  • GA-MA790x Gigabyte AM3 Motherboard (SB 750)
  • 4GB (2x2GB) 4-4-4-12 800mhz G.Skill Memory (1066 doesnt work with my board, go figure..)
  • AMD Phenom II X3 720 [email protected] Unlocked Fourth Core (AMD Phenom II x4 955 Equivalent)
Previously I had RadeonPro (3rd party software) set to Alternate Frame Rendering, which gave decent performance. But anything reflective would constantly flicker and night races would look awful.

I tried Ekko's steps, and exited RadeonPro, and to my surprise any and all Flickering is gone! Unfortunately I've experienced two problems:
  1. Anti-aliasing still isn't present, plenty of ugly jaggies
  2. Performance is still at 30-40 FPS, so no performance gains
  3. This may or may not be due to the fact that I hooked my computer up to my 26" 720P TV. It runs at 1376 x 768, so setting the game to run at 1920 x 1080 results in an awful looking image, but 1280 x 1024 (a 4:3) resolution won't really look too good on a wide screen TV either.
What am I doing wrong? I used the exact settings used by Ekko, and no matter what resolution I use, Jaggies are still present. Performance isn't there either, but I think that may be out of our hands. There's no way I can run HL2 Episode 2 at over 100 FPS maxed 4x AA and 4x Anistropic. HDR, all that eye candy and can't run this game over 50 FPS at a lower resolution than my monitor's 1680 x 1050...
 
1 - 20 of 29 Posts
Top