Overclock.net banner

Site Performance, what is it like for you ?

  • It is fine, same speed as other sites I use

    Votes: 25 21.9%
  • It could be better, slower than other sites I use ALL THE TIME

    Votes: 29 25.4%
  • It could be better, slower than other sites I use SOME OF THE TIME

    Votes: 29 25.4%
  • Terrible, much slower than other sites I use.

    Votes: 31 27.2%
101 - 120 of 135 Posts

·
Senioritis Member
Joined
·
8,396 Posts
Trust me when I say I understand, I am on the front line daily with these issues and more so, so I get the feeling of being let down by delays, the frustrations of site performance and the lack of features that we all should have by now...
Let me hasten to say I am NOT blaming you. The fault rests solely with the greed, apathy, and incompetence of VS.
 

·
Overclocker in training
Joined
·
14,315 Posts
Hi,
We may need a new poll :)
 

·
Still here...
Joined
·
5,035 Posts
Just some additional info for those interested here:

While data collected using browser-based developer tools like those already mentioned here can be helpful, that data has its limitations in that it's data collected on the client side of the Client-Server equation. Only so much troubleshooting can be done using it. What's really needed is for someone who has access to the server at the web host to take what's being reported (e.g., stalled requests from the client side, etc.) and attempt to pinpoint why those requests are stalling.

That can only be done using detailed server metrics, and only by someone knowledgeable enough to interpret them properly (and, if needed, use them in conjunction with other tools (see one of many examples) on the server side to further troubleshoot server performance and address issues associated with it).

Unfortunately (depending on your pov), I don't have that access so that someone is not me.
 

·
Premium Member
Joined
·
29,533 Posts
Just some additional info for those interested here:

While data collected using browser-based developer tools like those already mentioned here can be helpful, that data has its limitations in that it's data collected on the client side of the Client-Server equation. Only so much troubleshooting can be done using it. What's really needed is for someone who has access to the server at the web host to take what's being reported (e.g., stalled requests from the client side, etc.) and attempt to pinpoint why those requests are stalling.

That can only be done using detailed server metrics, and only by someone knowledgeable enough to interpret them properly (and, if needed, use them in conjunction with other tools (see one of many examples) on the server side to further troubleshoot server performance and address issues associated with it).

Unfortunately (depending on your pov), I don't have that access so that someone is not me.
I'm also getting the impression most of the stalling is server side.
My DevTools are reporting server wait times of 1500-6000 ms per page and most assets are loaded quickly.

The exception is attachment.php which also stalls for at least 1000ms before sending any data.

I've attached a DevTools screenshot of page 1 (at 100 posts per page) of this thread.

(for posterity: Firefox 62.0.2, Arch Linux. Relevant extensions: Ublock Origin)
 

Attachments

·
Still here...
Joined
·
5,035 Posts
I'm also getting the impression most of the stalling is server side.
My DevTools are reporting server wait times of 1500-6000 ms per page and most assets are loaded quickly.

The exception is attachment.php which also stalls for at least 1000ms before sending any data.

I've attached a DevTools screenshot of page 1 (at 100 posts per page) of this thread.

(for posterity: Firefox 62.0.2, Arch Linux. Relevant extensions: Ublock Origin)
Could also be hokey scripting of course, especially given the sort of Frankenstein monster that's likely been cobbled together over the years by VS to manage their VBulletin-based, "multi-forum" platform. Regardless, that too could be determined by a savvy admin.

I did take note of the initial 5+ seconds that expired after you clicked on the link and before the page started to load.
 

·
Overclocker in training
Joined
·
14,315 Posts
Hi,
Always quick to blame UBlock origin come on lol
If this site didn't run 25-35 scripts being reported none of us would need it :)
 

·
Still here...
Joined
·
5,035 Posts
Hi,
Always quick to blame UBlock origin come on lol
If this site didn't run 25-35 scripts being reported none of us would need it :)

Not sure anyone was blaming anything here, but the additional scripts supporting ads (and data collection) don't help of course. I'm fairly sure @gonX's mention of the enabled extension was simply because it was (indeed) relevant to the troubleshooting process.

Drawing samples in both cases (extensions on/off) helps in pinpointing specific problems on both the client and server sides, as well as the network in between them. Given what I've seen thus far here, I'd be focusing more on the instances where it initially takes the DOM longer to start loading (e.g., after clicking on a "link" here) or doing something that initiates another process/child process (e.g., opening/using the Attachments Manager, opening the Advanced Reply Editor, etc.).

Key Apache performance metrics provides a nice example (in Apache's case) of what we should be trying to accomplish here, and shouldn't be too hard to follow.
 

·
Administrator
Joined
·
64,444 Posts
Discussion Starter · #108 ·
I'm also getting the impression most of the stalling is server side.
My DevTools are reporting server wait times of 1500-6000 ms per page and most assets are loaded quickly.

The exception is attachment.php which also stalls for at least 1000ms before sending any data.

I've attached a DevTools screenshot of page 1 (at 100 posts per page) of this thread.

(for posterity: Firefox 62.0.2, Arch Linux. Relevant extensions: Ublock Origin)

Thanks for pitching in bud !
 

·
:)
Joined
·
11,146 Posts
1. EU, Norway
2. Slow performance often
3. Latest Opera with AdGuard addon(56.0.3051.36)
4. Extra info: Currently using 350mbit internet connection, Windows 10 Pro and all drivers updated to latest version with sig rig.

Have had several slowdowns and issues with loading OCN lately, several times it loads in only first post in any thread and need to refresh with F5 in order to load. Other times it seems to not load at all/connectivity issue.
OCN has been fairly slow for me over many years, but lately it has been extra slow.

EDIT: Sorry wrote wrong, should be slow performance often not at all times.
Best of luck to OCN crew :)
 

·
:)
Joined
·
11,146 Posts
Ran the new test, and got some screenshots for you.

Pasted in from last post:
1. EU, Norway
2. Slow performance often
3. Latest Opera with AdGuard addon(56.0.3051.36)
4. Extra info: Currently using 350mbit internet connection, Windows 10 Pro and all drivers updated to latest version with sig rig.
 

Attachments

·
Original 16-bit Genesis®
Joined
·
1,775 Posts
Ran the new test, and got some screenshots for you.

Pasted in from last post:
1. EU, Norway
2. Slow performance often
3. Latest Opera with AdGuard addon(56.0.3051.36)
4. Extra info: Currently using 350mbit internet connection, Windows 10 Pro and all drivers updated to latest version with sig rig.



That's consistent with the browser based testers. The delivering of HTML takes ages.
 

·
9 Cans of Ravioli
Joined
·
22,366 Posts
Haven't had a page not load past the banner in at least a few days. Really haven't been paying a whole lot of attention to speed but it hasn't been slow enough for me to rage and close the tab so that's neat.
 

·
Administrator
Joined
·
64,444 Posts
Discussion Starter · #116 ·
Haven't had a page not load past the banner in at least a few days. Really haven't been paying a whole lot of attention to speed but it hasn't been slow enough for me to rage and close the tab so that's neat.

Thanks, I will certainly take the minimized rage aspect !

For anyone reading, please send in your data by undertaking the below

For those that find site performance to be degraded only at certain points, please include the following in a post and use the below online diagnostic tool.

1. Your country.
2. Approx time frame of degraded performance.
3. Browser kind and version used.
4. Browse to UPTRENDS
5.Enter ''Overclock.net'' into the ''I want to test field''
6. Select the appropropriate options for Screen Size & Browser Type & Server Location (That best suits your geographical location)
7. After the test has completed please supply us with screenshots. Please see below the screenshots we require for the best diagnosis.

https://www.overclock.net/forum/255...ed-assessment-your-thoughts.html#post27547090
 

·
Administrator
Joined
·
64,444 Posts
Discussion Starter · #117 ·
After a call with VerticalScope....


As an update.

I have just finished a call with VS.


1. Site performance has been on their radar for some time as with many other of their sites under their wings. I have been informed that performance will be improving as they have shift thier proxy technology from ProxySQL to HA Proxy which has lead to some large performance increases across thier network, some improvements have been seen as large as 200ms to 5ms, there are factors involved and some sites will see more improvements than others but this is certainly a step in the right direction. Further to this they will be rebalancing all their server clusters to ensure best performance possible. As to the ETA to these changes, these changes are progressivley rolling out as we speak but I do not know a specific date for OCN, but I will look to get one as soon as I can unless the roll out beats me to it. As fair warning we may see some site loading errors while this process is underway.

As I know it is a concern and related to site performance, once we have seen the initial site improvements completed, I will approach the script and API side of things.

https://www.overclock.net/forum/22-...r-compare-issues-new-ocn-11.html#post27679954
 

·
Overclocker
Joined
·
11,688 Posts
In general it's on the slow side, it loves to take it's time to finish loading a page. This is persistent over long period of time.

Code:
Google PageSpeed score
57
[B]Load time
6.7 s[/B]
Size
5212.8 kB
Requests
127
Location
Berlin
Device
Desktop
Native
Browser
Firefox 61
Connection
Native speed
 

·
Administrator
Joined
·
64,444 Posts
Discussion Starter · #120 ·
It looks like VS are making the switch from ProxySQL to HA Proxy later today. All that is required from there end is a server reboot to make this happen. I have no timeframe of when today this is happening but I have been told that there will not be any downtime for the site.
 
101 - 120 of 135 Posts
Top