Overclock.net banner

1 - 13 of 13 Posts

·
Read Only
Joined
·
5,227 Posts
Discussion Starter · #1 ·
What I'm trying to accomplish is pretty simple and I've never had any issues in the past but I would like to install the latest version of Slackware (14.1 x64) onto my sig rig. So far, it's been nothing but a headache. I used unetbootin to put the .iso onto a USB flash drive (twice just to make sure it wasn't the issue)

I tend to get a few different outcomes, either:

A) The install completes 100% successfully without error, but simply boots into the BIOS after the install even with the correct boot order. (most common)

B) The install starts loading packages and then I get a kernel panic. I don't have the exact error message right now as I'm at work but I can provide it later if needed.

C) The install starts loading packages and then crashes with a different error that again, I do not have readily available.

Both B and C I *think* I have narrowed down to simple BIOS settings and with a tweak here and there I can usually get past them but will always end up getting stuck at A.

At first, I believed that it could be the hard drive when I was having some issues formatting it but after pulling it and testing another drive, I get the same results. I have two hard drives, the one in my sig with Windows 8.1 installed on it and a Hitachi Deskstar 80GB drive (the one I would rather put Slack onto). I have tried with only the 320GB drive and partitioned it to make room for both Windows and Linux+swap, just the 80GB drive and only Linux, and with both drives, same three outcomes.

I know that Slack is fully installing because I can boot into a Linux Mint Live USB that I made and mount/modify files from the Slack install. I haven't tried installing Mint yet instead of Slack, but I will try that as soon as I get home. I have tested the ISO in VirtualBox and it works fine and I have reformatted the USB drive to hopefully rule it out as a cause.

Across the various issues/error messages in my searches I've found a lot of information about UEFI motherboards and Secure Boot causing issues with Linux installations and when paired alongside Windows 8. I checked in msinfo32 and BIOS mode shows Legacy.

I don't get stumped often with this kind of stuff anymore but this has been throwing me in a loop for about a week now. I would think that with the BIOS set to boot from the USB, the installation completing *successfully*, and when not even trying to dual boot, that Slack should work just fine on my sig rig.

Any thoughts or recommendations on what to try next? My gut is making me want to pursue the UEFI aspect of this to see if that's causing the issue, but I'm not entirely sure.

And yes, I've read the Slack manual and followed it to the letter.
tongue.gif
 

·
10 year OCN Vet
Joined
·
3,422 Posts
Hello. Sorry you're having probs. I can probably help.

First things first since you're convinced the entire install is successful (although I'm wondering about your bootloader install, later for that). Slackware has a really nice feature on it's install media. In less than a second from initial boot you should be at a prompt with a short paragraph of information. If you know what partition your Slackware Root is, you can boot it from there. In fact the info allows you to choose what kernel and offers advice. On an X64 install the default kernel is "huge.s", called that because it has most modern modules "wired" at kernel level so it can even often boot systems with no, or a broken, initrd.

So let's say your root system is on /dev/sda3. As it states on that prompt page, all you should need to do, assuming it is an uncorrupted, complete install is

Code:

Code:
huge.s root=/dev/sda3 rdinit= ro
If it won't boot, the install is either incomplete, corrupted or both. BTW what file system did you choose?

If it does boot, then it is likely your bootloader install was incomplete. If this is the case I suggest you read at least the appropriate sections of Slackbook H E R E

I'll watch for this thread to see you through successfully. Don't worry. It's gonna run great.
 

·
Premium Member
Joined
·
8,040 Posts
Quote:
Originally Posted by enorbet2 View Post

I'll watch for this thread to see you through successfully. Don't worry. It's gonna run great.
I saw this thread and was considering replying then I thought about you and that you'd give far better advice on this than I would
thumb.gif
 

·
Read Only
Joined
·
5,227 Posts
Discussion Starter · #4 ·
Quote:
Originally Posted by enorbet2 View Post

Hello. Sorry you're having probs. I can probably help.

First things first since you're convinced the entire install is successful (although I'm wondering about your bootloader install, later for that). Slackware has a really nice feature on it's install media. In less than a second from initial boot you should be at a prompt with a short paragraph of information. If you know what partition your Slackware Root is, you can boot it from there. In fact the info allows you to choose what kernel and offers advice. On an X64 install the default kernel is "huge.s", called that because it has most modern modules "wired" at kernel level so it can even often boot systems with no, or a broken, initrd.

So let's say your root system is on /dev/sda3. As it states on that prompt page, all you should need to do, assuming it is an uncorrupted, complete install is

Code:

Code:
huge.s root=/dev/sda3 rdinit= ro
If it won't boot, the install is either incomplete, corrupted or both. BTW what file system did you choose?

If it does boot, then it is likely your bootloader install was incomplete. If this is the case I suggest you read at least the appropriate sections of Slackbook H E R E

I'll watch for this thread to see you through successfully. Don't worry. It's gonna run great.
I agree that even though the install completed without error that the bootloader could still be an issue, so absolutely I'll check it out
thumb.gif
.

As for this:

Code:

Code:
huge.s root=/dev/sda3 rdinit= ro
Where do I put that if I can't access the grub/liloat all?

Quote:
Originally Posted by Plan9 View Post

I saw this thread and was considering replying then I thought about you and that you'd give far better advice on this than I would
thumb.gif
Hey, any help is appreciated, input, comments, whatever, I won't complain.
smile.gif


EDIT:

I just installed Mint over top of Slackware and it still boots straight into Windows if that disk is in, and straight back into the BIOS if it isn't.
 

·
10 year OCN Vet
Joined
·
3,422 Posts
I guess I wasn't clear enough. Boot your install media and within less than a second the very first screen you stop at is a lilo boot prompt with instructions.

EDIT: Just saw your edit and the cause is now obvious if still a bit wide - some setting in your UEFI/BIOS, most likely one that caters to Windows, is set to "enabled" instead of "auto" or "disabled". I actually downloaded your board's BIOS Manual and there are several. It's even possibly your MRC Fast Boot setting so it's going to require some searching and deeper understanding of how your BIOS works (actually a good thing
smile.gif
)

PS Do be certain to start with CSM to "Auto". If it is, try "Enabled". If the latter works and the former didn't bios is buggy - get latest until it's fixed.
 

·
10 year OCN Vet
Joined
·
3,422 Posts
Quote:
Originally Posted by Plan9 View Post

I saw this thread and was considering replying then I thought about you and that you'd give far better advice on this than I would
thumb.gif
Five.... Up High XD
 

·
Read Only
Joined
·
5,227 Posts
Discussion Starter · #7 ·
Quote:
Originally Posted by enorbet2 View Post

I guess I wasn't clear enough. Boot your install media and within less than a second the very first screen you stop at is a lilo boot prompt with instructions.

EDIT: Just saw your edit and the cause is now obvious if still a bit wide - some setting in your UEFI/BIOS, most likely one that caters to Windows, is set to "enabled" instead of "auto" or "disabled". I actually downloaded your board's BIOS Manual and there are several. It's even possibly your MRC Fast Boot setting so it's going to require some searching and deeper understanding of how your BIOS works (actually a good thing
smile.gif
)

PS Do be certain to start with CSM to "Auto". If it is, try "Enabled". If the latter works and the former didn't bios is buggy - get latest until it's fixed.
CSM was originally set to auto during all of the above. I just tried it with it set to "Enabled" with the same result.
 

·
Registered
Joined
·
1,526 Posts
Quote:
Originally Posted by enorbet2 View Post

If the latter works and the former didn't bios is buggy - get latest until it's fixed.
This is a good point actually. Have you updated your BIOS to the most recent version? It may not be responsible for this issue, but an up-to-date BIOS is always a good idea.
 

·
Read Only
Joined
·
5,227 Posts
Discussion Starter · #9 ·
Quote:
Originally Posted by Ferrari8608 View Post

This is a good point actually. Have you updated your BIOS to the most recent version? It may not be responsible for this issue, but an up-to-date BIOS is always a good idea.
Indeed I have.

I'm starting fresh right now. Currently formatting and partioning the drive using cgdisk.

Okay I have an update. After yet another installation formatted using cgdisk with an EFI, swap, and ext4 partition, I booted using the install USB and selected to detect installed os's in the grub v2 menu, I get a bunch of errors flash across the screen then an entry for (hd1,msdos1)/EFI/boot/bootx64.efi

If I try to boot it I get put back to the initial grub screen. If I hit "e" to edit the commands it says,

Code:

Code:
Setparams '(hd1,msdos1)/EFI/boot/bootx64.efi' 'hd1,msdos1'

                                              Efi_devices="$2"
                                              Efi="$1"
                                              If [ "$grub_platform" = "EFI" ]; then
                                                         Root="$efi_device"
                                                         Chainloader "$efi"
                                              Else
                                                         Echo $"sorry but we are booted via bios and cannot load to this OS."
                                                         Echo $"please try booting SGD2 via uefi. "
                                                         Echo $"press escape to return to the menu."
                                                         Sleep --interrupt able 9999
                                              Fi
EDIT #2:
I was able to get a video of the errors so I could slow them down. After selecting to detect installed OS's the error says,

Code:

Code:
error: unknown filesystem.
and after selecting (hd1,msdos1)/efi/boot/bootx64.efi" it says,

Code:

Code:
/EndEntire
file path: /ACPI(a0341d0,0)/PCI(0,14)/USB(3.0)
/HD(1,2,ee8bfe,0000000000000000,0,0)/File(\efi\boot).
/EndEntire
Edit #3

After what has been a very long day, I was able to get windows 8 on one drive and mint on the other but now instead of booting straight into the BIOS it just goes to a grub prompt. That's if I select the mint disk as the first boot device.
 

·
10 year OCN Vet
Joined
·
3,422 Posts
It seems to me you have confused your system by setting the UEFI BIOS to "Legacy" which understands MBR partitions, but creating EFI partitions which Legacy does not understand. I think you need to choose.

Either

1) use EFI bios setting and partitions and employ eLilo or grub-efi for any Linux

or

2) use Legacy Bios and Partitions and legacy Lilo and Grub or Grub2
 

·
Read Only
Joined
·
5,227 Posts
Discussion Starter · #11 ·
Quote:
Originally Posted by enorbet2 View Post

It seems to me you have confused your system by setting the UEFI BIOS to "Legacy" which understands MBR partitions, but creating EFI partitions which Legacy does not understand. I think you need to choose.

Either

1) use EFI bios setting and partitions and employ eLilo or grub-efi for any Linux

or

2) use Legacy Bios and Partitions and legacy Lilo and Grub or Grub2
Makes sense. I ended up even reinstalling Windows yesterday as a bit of housecleaning and msinfo32 now shows it as UEFI. When I boot into the Mint live USB and open terminal to check how it booted up I get this:

Code:

Code:
[email protected] ~ $ dmesg | grep "EFI v"
[    0.000000] efi: EFI v2.31 by American Megatrends
[email protected] ~ $
So with Windows set properly, and booting from Linux Mint getting this outcome, I should be able to install Slackware and use ELILO at the end of the install and everything should work. I think. This newfangled UEFI stuff is..interesting.

Now with EFI partitions and settings, where should ELILO be installed?
 

·
Read Only
Joined
·
5,227 Posts
Discussion Starter · #13 ·
Quote:
Originally Posted by enorbet2 View Post

Greetz
I have yet to "upgrade" to UEFI completely, still preferring Legacy Mode, so I have to defer and refer you to Slackdocs once more. This is quite thorough and well described so should be fairly easy to accomplish. See Slack Docs UEFI + eLilo - HERE
No worries at all, you've been a huge help. +Rep!
 
1 - 13 of 13 Posts
Top