Overclock.net banner

Sony Vegas shows audio, but no video?

2800 Views 10 Replies 3 Participants Last post by  Coma
yep, I just installed it, and I tried to test it, I imported a video in .avi format (I think it uses DivX) b ut it just showed audio, but no video.

This is weird because windows 7 is supossed to have all the DivX codecs preloaded. So what do you guys think it might be?

also, is there a way to accelerate encoding via GPU?

See less See more
1 - 11 of 11 Posts
There was a thread just like yours a few days ago.
Vegas doesn't decode dvix. I've tried looking for extra codecs to install for it, but I've never found anything.

And no you can't accelerate the preview window or encoding (don't see why you would want to, GPU encoding sucks).
and pinnacle studio 14?
Try it.

Though I am skeptical about Vegas not doing MPEG-4 ASP. It seems to me that it uses VFW, so you should be good with CCCP. After installing, you should check ffdshow's VFW decoder settings to see that the divx/xvid/asp decoder is enabled.

In the other thread I mentioned the problem was solved after installing codecs, so I'm pretty sure it doesn't rely solely on internal codecs.
I installed DivX 7 and Xvid, it seems like it opens some .avi videos now lol
Why would you install both of those? Like I said, just install CCCP...

DivX 7 isn't even the kind of DivX you need. It's AVC, not ASP.

This is how people break their setups with tons of codecs and then don't understand why something doesn't work.
HOLLY sh--

I never have been able to get .avi (xvid) scene files to be able to import to Vegas... I just gave up a loooong time ago. Now I guess with CCCP it works.

mind = blown
You can always remux them to MP4. That's how they're really supposed to be packaged, rather than AVI.
err huh?

ok sorry... didn't know that...

anyway, I just installed CCCP and it works wonderful now! thanks!

BTW if I uninstall DixV and XviD, and keep CCCP installed, can I still open that kind of videos? (this is for a laptop with windows XP).
Yes, but the uninstallers might screw with the codec priority (there's some other word for it which I can't seem to remember), so I suggest running the CCCP config utility afterwards and checking "reset all settings" and "re-register filters".
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.