Overclock.net banner
1 - 14 of 14 Posts

·
Registered
Joined
·
287 Posts
Discussion Starter · #1 ·
So, I just finished putting together all the parts in my sig. I plug the power cord into my power supply, plug the other end into the wall and...

nothing.

I'm flummoxed. Is there something really simple and obvious that I'm overlooking or should I start unplugging the connectors in preparation for the inevitable buy.com rma process?

Problem solved. I'm ******ed. Thanks to those of you who took the time to help me with my nonexistent problem.
 

·
Banned
Joined
·
3,854 Posts
Make sure the switch on the back of the psu is on. And make sure the power button is plugged in correctly.
 

·
Premium Member
Joined
·
3,463 Posts
also, make sure the case leads are in the right location.

just for kicks (in case you got it backwards) hit the reset button on the case.
you may have the power/reset leads mixed up.
 

·
Registered
Joined
·
287 Posts
Discussion Starter · #5 ·
Quote:


Originally Posted by crashnburn_819
View Post

Could be a lot of things.
Power switch is off
Ram is dead
CPU is dead
Cable somewhere is bad or not plugged in all the way

The power supply isn't turning on at all. How is that a function of the ram or cpu? Actually, I didn't mention that so I guess that's a fair assessment of what could be wrong. Am I wrong in thinking that at least the power supply fan would come on even if the cpu or ram were dead?

Quote:


Originally Posted by McStuff
View Post

Make sure the switch on the back of the psu is on. And make sure the power button is plugged in correctly.

The switch on the back of the psu is on and I've just made sure that the cord on both ends is secured. Still nothing.
 

·
Registered
Joined
·
2,837 Posts
if the motherboard has a built in on/off switch, unplug your case leads and try using that to power the system on

Do the mobo lights come on when the power is plugged in but the system is not on? What exactly does it do.
 

·
Registered
Joined
·
1,921 Posts
so the computer doesnt turn on at all?

or does it turn on, but monitor = blank?

describe a little more plz
 

·
Registered
Joined
·
287 Posts
Discussion Starter · #8 ·
Hahahahahahaha. God, I'm ******ed. I plugged my comp into a socket in my new apartment that requires a light switch to be turned on for the power.

Flipped the switch and everything's gravy.

Thanks guys for briefly indulging my idiocy
.
 

·
Registered
Joined
·
870 Posts
Wow, great you got that working.
When I read the thread title I thought you were posting about the plot of Crysis.
 

·
Registered
Joined
·
101 Posts
Quote:


Originally Posted by thecool85
View Post

Hahahahahahaha. God, I'm ******ed. I plugged my comp into a socket in my new apartment that requires a light switch to be turned on for the power.

Flipped the switch and everything's gravy.

Thanks guys for briefly indulging my idiocy
.

Nice!
 

·
Registered
Joined
·
287 Posts
Discussion Starter · #14 ·
Quote:


Originally Posted by smoke12291
View Post



lol

I hate it when I do stuff like that...which is a lot...


glad to hear it's working.

Yea, I try to limit the amount of times a day that I'm ridiculously oblivious to the simplest of things, but nevertheless, I still have a fair amount of boneheaded blunders attributed to my name
. Thanks for the sympathy and the well wishes.

Quote:


Originally Posted by Murderous Moppet
View Post

Wow, great you got that working.
When I read the thread title I thought you were posting about the plot of Crysis.

You know, I haven't played crysis yet, but I did get it for $10 yesterday at best buy. I'll finally get a chance to truly understand all the Crysis jokes that I read on forums all day.
 
1 - 14 of 14 Posts
Top