Overclock.net banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello all,

I have a Sound Blaster Z sound card in my PC that I've had for about a year and a half. I'm using the Toslink output to my Astro A50 headset. Ever since using Windows 10 (about a year now), and trying various manufacturer driver versions, I continue to have a specific problem. At random times at least once every 24-hours, the audio starts to become choppy as in, it cuts in and out quite frequently (every few seconds, for .5 - 2 seconds in duration) and I get popping noises in my headphone earcups. It affects the sound system-wide until I reboot. Then it's back to normal again until the next time it happens, always within 24-hours of the PC being on (which of course facilitates a reboot at least once per day). I have isolated the issue to the SB Z because when the problem occurs, I switch the optical cable to my on-board sound and it works fine (though it doesn't sound as good as the SB Z, since it's an ALC898). Switching back to the SB Z and I hear the problem again until a reboot.

Here is what I have set:

Sound Blaster Z Device:
-Default Format: 24 bit, 48.0 kHz (have tried down to 16 bit, 44.0 kHz)
-Exclusive Mode enabled (have also tried disabled, no beneficial effect)
-Signal Enhancements enabled (have tried disabled, no beneficial effect)

SPDIF-Out Sound Blaster Z Device:
-Formats: Dolby Digital (my headset does 7.1 using Dolby Digital, doesn't support DTS)
-Sample Rates: 48.0 kHz
-Default Format: 2 channel, 24 bit, 48.0 kHz (tried the same as above)
-Exclusive Mode enabled (tried the same as above)

Sound Blaster Pro Studio Software
-SBX Pro Studio enabled, only Surround checked.
-Crystal Voice disabled
-Scout Mode disabled
-Speakers Config: 5.1 surround (center, subwoofer and rear l/r)
-Cinematic: Dolby Digital Live

I've also tried disabling via BIOS the on-board sound, no help.

I'm at a loss for next steps to try. I've already disabled/enabled virtually every setting on the software and sound devices when the issue happens, I have re-installed the drivers (multiple versions) at least 4 times (fully uninstalled/cleaned and a fresh install each time), and absolutely nothing helps resolve it (except for a reboot). It's isolated to the SB Z card as described above (headset and sound work fine if immediately plugged into the on-board sound device), so at this point I'm thinking it's either a driver issue that is unresolved with Creative and Windows 10, or a faulty card.

Any suggestions?
 

·
WaterCooler & Overclocker
Joined
·
2,590 Posts
I have a similar problem. I use the optical out to Turtle Beach wireless headphones, also on Windows 10. The headphones have been crackling when gaming, or watching videos. I thought my headphones were going bad!

So I switched the optical cable to on-board sound and they sound great, so I know it's not the headphones.

That is the extent of my troubleshooting so far. I have not tried to re-boot to see if that make a difference.

I also have a Sound Blaster ZXR just sitting in a box, so I plan to swap the sound cards next weekend and see if that makes a difference. I'll report back once I've done that.
 

·
WaterCooler & Overclocker
Joined
·
2,590 Posts
I put my ZXR in last weekend and I get the same crackling noise. I have it in my last/bottom slot with three GPUs above it. After some searching around, I see others with similar issues. I went back to the on-board sound and it works fine.

At this point I think my problem is system/motherboard related, so for now I'm just going to use onboard sound. Let me know if you find a fix for yours.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Never did get a permanent solution. The official sound blaster Creative forum moderator gave me a registry tweak to see if it helps, it didn't. I would go back to on-board sound too, but it doesn't sound as good unfortunately.

My current solution is simply do an automated system restart at 3am everyday, since restarting once per day fixes the issue.
 
1 - 4 of 4 Posts
Top