Overclock.net banner

1 - 20 of 20 Posts

·
Registered
Joined
·
233 Posts
Discussion Starter · #1 ·
Hey everybody! So limiting my FPS to 60 definitely improved the smoothness, but I'm still getting screen tearing. More specifically, a weird kind of screen tearing that happens slowly - it's like a line goes slowly up my screen. Does anyone know what I'm talking about?
 

·
Registered
Joined
·
24 Posts
Can you screenshot the Tweaks tab of RadeonPro. That line you describe going slowly up the screen is definately the sync.

Have you tried FPS at 59? Also, What is your monitor refresh rate set at in Windows? 60 or 75Hz? or more?

Also make sure any CCC and in game Vsync is sent to none/application controlled.

Does the line appear in all games? Or just one?
 

·
Registered
Joined
·
24 Posts
To get the monitor refresh rate, right click the desktop and go to where you can change your Rsolution (not sure if you have Win8 or Win7) as the procedure is different. Then go to Advanced.. and the Monitor tab.

But before that. Go to RadeonPro. Uncheck Dynamic Framerate Control and Check Lock frame rate up to Monitors Refresh Rate instead.

Try that.
 

·
Registered
Joined
·
2 Posts
I'm having the exact same problem. First time I use RadeonPro. I even set my Dynamic Frame Rate to 45 where as my screen refresh rate is 60 just to see what happens and there still tearing, very small, but noticeable. Tried locking it to my refresh rate, thats even worse. I can see the FPS counter in game as the game itself has a FPS counter, and RadeonPro does what it's suppose to, just it doesn't eliminate screen tearing. I know I must be doing something wrong, just not sure what. My in-game monitor refresh rate is 60. With VSync on it stays at 60.
 

·
Registered
Joined
·
2 Posts
I set my VSync control to Dynamic, not sure what it means, but the most of the tearing is gone.

Side note, does Triple-Buffering have to be enabled when I use Dynamic Framerate Control?
 

·
Registered
Joined
·
6 Posts
Quote:
Originally Posted by BobTheChainsaw View Post

Here's a screenshot of the RadeonPro settings:

http://i.imgur.com/UHYdml8.png

Yes, it happens in more than one game. And yes, I tried my FPS at 59, and I still got it. I'm pretty sure my refresh rate is 60 hz, how do I tell?
If you're using DFC, you must set "Always on" in VSync control dropdown or set VSync=On under game settings.
 

·
Registered
Joined
·
233 Posts
Discussion Starter · #8 ·
Hi! So I tried both alternatives - locking the frame rate and then combining DFC with Vysnc, and I'm still getting the tearing I described above. Keep in mind, though, that I only tested these later options with TF2, so it could be TF2 acting all funky.
 

·
Registered
Joined
·
233 Posts
Discussion Starter · #10 ·
Quote:
Originally Posted by japamd View Post

I guess your problem is not related to vsync, please check this out, might fix your issue as well.
Hmm, that's FIFA though, doesn't really apply to TF2 (i'm running on all max settings anyway.) You think I should make a post on the RadeonPro forums?
 

·
Registered
Joined
·
6 Posts
Quote:
Originally Posted by BobTheChainsaw View Post

Hmm, that's FIFA though, doesn't really apply to TF2 (i'm running on all max settings anyway.) You think I should make a post on the RadeonPro forums?
The recommended settings apply to any game.
Quote:
- In Visual tab, set AF to 16x

- In Advanced tab
* untick all optimization options
* Set Texture Filtering Quality to High Quality
* Set Mipmap Quality to High Quality
 

·
Registered
Joined
·
233 Posts
Discussion Starter · #12 ·
Sadly, that does not work.
frown.gif
I'm getting the issue in Mirror's Edge too, so I assume it's universal - I'm going to make a post on the official RadeonPro forums.
 

·
Registered
Joined
·
233 Posts
Discussion Starter · #13 ·
So an update, I get this tearing without RadeonPro when Vsync is off, but it's usually never this bad. It's like lines that are going up my screen - and it's weird, because I thought screen tearing only happened when you turned quickly? The fact that RadeonPro does not fix it might mean it might be something unrelated to screen tearing - drivers, overheating, etc. Anyone got any ideas?
 

·
Registered
Joined
·
91 Posts
What kind of monitor are you using and what connector is it connected to? I remember having tearing even with all kinds of VSync and framecapping etc on my old 1680x1050 monitor connected via D-Sub/VGA.

If you're on an analog connection, change to a digital (HDMI, DVI, DisplayPort etc) if possible, I got a new monitor with DVI and I have never had the same problem since.
 

·
Registered
Joined
·
233 Posts
Discussion Starter · #15 ·
I'm plugged in via HDMI, but I'll try DVI and see if that fixes it. Also, I'm on the latest beta drivers, so it very well could be an issue with them.
 

·
Registered
Joined
·
1,920 Posts
Normally i do Refresh Rate - 1 as my frame limiter and i dont get any tearing in games (with vsync off)

Oh wait - this is with Afterburner. Maybe try that?
 

·
Registered
Joined
·
1 Posts
Had the same problem as you describe, following settings fixed it for me:

Visual:
Enable only AF
- set to 16x

Advanced
Enable only these:
1. "Force Triple-buffering (OpenGL)"
2. Texture Filtering Quality
- Set to "High Quality"
3. Mipmap Quality
- Set to "High Quality"

Tweaks
Vsync Control (Drivers Default)
Enable only "Lock frame rate up to monitors refreshrate".
And of course enabling all the CPU affinities.

I have no launcher selected (it just messes up my SKSE, dunno why)
My main trigger is set to SKSE_loader.exe
Alias is set to TESV.exe

I hope this can help you out mate. I'm running fullscreen by the way - no settings changed in skyrim options, just default ultra.
 
1 - 20 of 20 Posts
Top