Overclock.net banner

1 - 14 of 14 Posts

·
Registered
Joined
·
511 Posts
Discussion Starter #1
Designing and building this thing took almost a month. A lot of care and heart went into this build. I wanted a lot of aesthetic appeal without any lagging in performance. It's been a long journey with some pitfalls and frustration, but now it's done and I'm 100% happy.

If anyone wants to see more detailed pics I'll be happy to oblige. Full loop spec is below.





All Koolance blocks for CPU and mobo
Swiftech PMC655
Swiftech 360 rad
XSPC single bay res
Tubing is all UV blue
 

·
Registered
Joined
·
196 Posts
Sweet! Love the color....
 

·
Registered
Joined
·
511 Posts
Discussion Starter #8
Quote:

Originally Posted by murky44 View Post
Wow, that looks absolutely beautiful


If you don't mind me asking, what are your CPU temps at full load?
My temps are bothering me a bit to be honest. Mostly because my last setup had lower temps and it was a (supposedly) inferior loop.

Right now I'm 42 at idle and 76 after 10 minutes of prime blend.

Isn't that a bit high even for 4.2ghz?
 

·
Registered
Joined
·
4,669 Posts
Quote:

Originally Posted by james... View Post
My temps are bothering me a bit to be honest. Mostly because my last setup had lower temps and it was a (supposedly) inferior loop.

Right now I'm 42 at idle and 76 after 10 minutes of prime blend.

Isn't that a bit high even for 4.2ghz?
How long has your loop been active? maybe the TIM has not seated yet
or more likely you need to reset your CPU

Nice work on the case
 

·
Registered
Joined
·
511 Posts
Discussion Starter #10
Well the thing is...my cpu block has been seated the same way for weeks.

And the temps were much lower on my last setup (crappy)
 

·
Registered
Joined
·
71 Posts
Load temps are a little bit on the high side, but then again, you're at 4.2, and cooling nb, sb, and MOSFET as well all in one loop. Were you cooling all of that in your last setup also?
 
1 - 14 of 14 Posts
Top