Overclock.net banner

1 - 20 of 89 Posts

·
Registered
Joined
·
465 Posts
Discussion Starter #1
I'll preface this saying I don't have a fix for ATI, assuming ATI owners are having CrossFire problems. This thread is SLI only.

What is this fix?

This is a Nvidia Inspector tweak that makes SLI work in Witcher 2. Currently it doesn't. After this fix you should see noticeable FPS improvements w/SLI. For example, with SLI GTX 580s you'll see a considerable gain in FPS at Ultra Spec w/UberSampling enabled. That said, there may still be more room for improvement down the road in official driver/game updates.

Problems

None to my knowledge, however I've only tested this fix for my GTX 580 TRI SLI; if this fix doesn't work for your other cards then maybe it's card specific? If you somehow mess up in Nvidia Inspector, at worse you may need to reinstall your Nvidia drivers.

I've heard of a "light leaking" bug with SLI, that is possibly fixed by forcing AFR2 (Alternate Frame Rendering 2) for The Witcher 2 (either through Nvidia Inspector or the Nvidia Control Panel). I haven't seen that bug yet.

Prerequisites

This fix has been tested to work for Nvidia drivers 270.61 (stable) and 275.27 (beta). There is no FPS improvement between the two after much testing. The beta drivers however have improved 3D Vision compatibility for The Witcher 2, and maybe other non-documented tweaks.

Instructions

1. Download and install Nvidia Inspector. (latest version to my knowledge is 1.9.5.5)

2. Open Nvidia Inspector. Click on the tool button at the right of the "Driver Version" box. This opens up the Profile Settings editor.

3. In the "Profiles" drop-down select "The Witcher 2". Under "Compatibility" (first section) look for "SLI compatibility bits". You want to change this field's value from whatever it is to 0x02C04205.

4. Hit "Apply Changes". You're done! There's no need to change anything else.

nvidiainspectorstep1.png


nvidiainspectorstep2.png


My Results

First, here's my game settings:

witcher2settingsultra19.png


Everything maxed, UberSampling enabled. My native resolution is 2560x1600, but since most people have 1080 monitors I'm testing at that resolution.

Without Fix:

Average FPS - 26
Average Usage - 40%

gpuusageslibroke.png


averagefpsslibroke.jpg


Video (Fraps @30)

[ame]http://www.youtube.com/watch?v=Sx6_25X0np0&hd=1[/ame]

With Fix:

Average FPS - 56
Average Usage - 83%
(at 2560x1600 usage for me was pretty much 99%)

Just for kicks, only with UberSampling disabled my FPS was above 120.

gpuusageslifixed.png


averagefpsslifixed.jpg


Video (Fraps @30)

[ame]http://www.youtube.com/watch?v=kteiCXx7oP4&hd=1[/ame]

Video (Fraps @60 - Best shows the vastly improved FPS)

[ame]http://www.youtube.com/watch?v=7QMaMTtBHI0&hd=1[/ame]
 

·
Registered
Joined
·
465 Posts
Discussion Starter #3
Here's with UberSampling off:

ubersamplingdisabledsli.jpg


[ame]http://www.youtube.com/watch?v=TALwJXCAxdU[/ame]

This is the first game I feel my TRI SLI is truly meant for.
biggrin.gif
Unlike DA2, this game is optimized amazingly for release. Haven't decided if I want to continue the game with UberSampling on or off. Game still looks great with it disabled. Even with the fix the FPS in heavy fights dips below 30, but with UberSampling off it's all gravy.
 

·
Registered
Joined
·
739 Posts
Nice guide buddy! I don't have a multi gpu setup but this will be very helpful for all the Witcher fans. Btw I'm loving this game so far. Best game I have ever played and the graphics and atmosphere is amazing. Sometimes I just look around and admire the land.

+rep
 

·
Registered
Joined
·
6 Posts
Quote:
Originally Posted by velocd;13571468
*snip*
This is my story.
I have latest beta drivers and the nvidia inspector compat bits but no matter what I try sli does not work for me.
I have 2 x 580gtx sli and an i7 950 @3.85 6 gig ram win7 64.
I have tried everything at every forum and cant understan it at all.
With unbersampling on my cards are at 98% but framerate is only 30 and too low for me. I want sli working without uber but as soon as I turn it off back to the same framerate as single card.
I see you are a programmer so perhaps you can help me with this.
I also have to say that their are other that can and can't get this fix working.
SLI and my rig works perfectly with every other game.
What else can it be that is keep my cards from working in sli properly without uber enabled.
Also when I press ctrl and bring up mini menu the framerate shoots up almost double in some scenes and the cards go up tp 99% as they do in cut scenes.
As far as I can tell when the ctrl is pushed the menu comes up on top of the rendered scene so framerate if anythink should go dowm. This means that perhsapd this is easily sorted but for now I need a fix.
 

·
Registered
Joined
·
1,062 Posts
it worked for me. Before SLI would only kick in 1 card to 99% while did other would sit around 4%. Now both cards are maxout at 99%. Still with uber enabled it runs smooth but u can see that the frame drops alot. I like my game running @ or above 60fps all the time. I really like how uber ON looks but now sure if i want such a hit perfomance. i get around 45-55 fps average but with Uber OFF i get 100's fps average.
 

·
Registered
Joined
·
465 Posts
Discussion Starter #13
Quote:
Originally Posted by darrensimmons;13574217
Hopefully someone will find out why it only works for some users?I have no luck with 580gtx sli.Tried everything.
Not sure either, only suggestion would be to restart from the beginning: uninstall drivers, run Driver Sweeper, restart, install latest beta driver w/clean install checked, restart, install Nvidia Inspector (latest) and make sure you modify the profile SLI bits exactly.

There could be one other discrepancy - your version of Witcher 2. I have the GOG edition (DRM free), but there's also the retail edition, Steam edition, and Direct2Drive edition. I can confirm it works for GOG. On other editions, maybe in the Nvidia Control Panel under Custom Profiles add the game's executable manually? (witcher2.exe) Then go into Nvidia Inspector and do its changes.
 

·
Registered
Joined
·
6 Posts
Quote:
Originally Posted by velocd;13576542
Not sure either, only suggestion would be to restart from the beginning: uninstall drivers, run Driver Sweeper, restart, install latest beta driver w/clean install checked, restart, install Nvidia Inspector (latest) and make sure you modify the profile SLI bits exactly.

There could be one other discrepancy - your version of Witcher 2. I have the GOG edition (DRM free), but there's also the retail edition, Steam edition, and Direct2Drive edition. I can confirm it works for GOG. On other editions, maybe in the Nvidia Control Panel under Custom Profiles add the game's executable manually? (witcher2.exe) Then go into Nvidia Inspector and do its changes.
Thanks for the reply. I have the retail version and have tried 3 sets of drivers. I'm back with betas again with 3d vision installed as it makes no difference to my set up which I find strange. I have even used the nvidia tool for importing and exporting profile to modify them which bypasses inspector completely.
So perhaps the fact that I have retail version with drm may be doing it, no way to find out really.
 

·
Registered
Joined
·
504 Posts
Works for me- bumps up the GPU usage and FPS. But I get artifacts during gameplay. They only last a few milliseconds but they're frequent enough to ruin immersion. They stretch from the corner of the screen to the middle, and they're narrow-triangular.
 

·
Registered
Joined
·
118 Posts
The original Witcher had an issue with SLI enabled. You would see a blur/haze around torches and sources of light and they would also be visible through walls. As far as I know that issue was never fixed...and has carried over to Witcher 2 !! I hope a patch fixes this.
 

·
Registered
Joined
·
504 Posts
Quote:
Originally Posted by CH33TAH;13579724
The original Witcher had an issue with SLI enabled. You would see a blur/haze around torches and sources of light and they would also be visible through walls. As far as I know that issue was never fixed...and has carried over to Witcher 2 !! I hope a patch fixes this.
By default I don't have this issue. I only get light leakage when I use the hex code from the OP.
 

·
Registered
Joined
·
3,534 Posts
Awesome guide
biggrin.gif
. Got it working with my 580s with the SLI hack on my CHIV using the 270.61 driver.
 
1 - 20 of 89 Posts
Top