Overclock.net banner

1 - 5 of 5 Posts

·
Banned
Joined
·
1,479 Posts
Discussion Starter #1
I have a three month old Toshiba q series pro from BestBuy but I am moving and I literally just threw out the box with the receipt because the drive was working perfectly prior to puling it and trying to sell it. Today I finally got a GPU back for main system so I got ready to boot and install windows again and lo and behold the ssd was not showing, I tried different power cables and all the sata cabes connected to the other drives that showed to no avail.

Connected via sata diskpart via windows install says it sees no logical disks, now hooked up to an AIO via a sabrent hotswap hub (JMicron controller) disk management sees the ssd as 0GB and tried to initialize it giving option for MBR or GPT but then errors out with i/o error....great! I decided to try and do RMA with toshiba but the website only lists option for a visa giftcard with $266 refund with proof of purchase in the box when you send it back however, mine is gone. but the drive manufacture date is Aug of 2015 well below the 3 month warranty has anyone been able to do the return without proof of purchase due to new manufacture date with them? or am I basically sol

Unless someone has a miracle solution to doing CPR on this thing

Edit: So far toshiba basically told me "We need the receipt to make sure the drive is under warranty still" even when I told them....unless Aug 2015 is 3 years ago there is no literal way it is not.
 

·
Gamer
Joined
·
1,244 Posts
Quote:
Originally Posted by Feyris View Post

I have a three month old Toshiba q series pro from BestBuy but I am moving and I literally just threw out the box with the receipt because the drive was working perfectly prior to puling it and trying to sell it. Today I finally got a GPU back for main system so I got ready to boot and install windows again and lo and behold the ssd was not showing, I tried different power cables and all the sata cabes connected to the other drives that showed to no avail.

Connected via sata diskpart via windows install says it sees no logical disks, now hooked up to an AIO via a sabrent hotswap hub (JMicron controller) disk management sees the ssd as 0GB and tried to initialize it giving option for MBR or GPT but then errors out with i/o error....great! I decided to try and do RMA with toshiba but the website only lists option for a visa giftcard with $266 refund with proof of purchase in the box when you send it back however, mine is gone. but the drive manufacture date is Aug of 2015 well below the 3 month warranty has anyone been able to do the return without proof of purchase due to new manufacture date with them? or am I basically sol

Unless someone has a miracle solution to doing CPR on this thing

Edit: So far toshiba basically told me "We need the receipt to make sure the drive is under warranty still" even when I told them....unless Aug 2015 is 3 years ago there is no literal way it is not.
BOOM! http://www.bestbuy.com/site/help-topics/getting-receipt-copies/pcmcat204400050026.c?id=pcmcat204400050026
 
  • Rep+
Reactions: bogdankr

·
Gamer
Joined
·
1,244 Posts
did this work out for you??
 

·
Gamer
Joined
·
1,244 Posts
Quote:
Originally Posted by Feyris View Post

It took a few tries but they did find it!
awesome! glad to hear!
thumb.gif
 
1 - 5 of 5 Posts
Top