Overclock.net banner

1 - 7 of 7 Posts

·
Registered
Joined
·
258 Posts
Discussion Starter #1
Ok my mobo is a gigabyte ma785gm-us2h and i was using the @bios download...it shows me version 5 is ready for download...so i download it and it restarts my computer...get in to bios and it is still version 2. Am i missing something about the bios update?
 

·
Intel/Nvidia
Joined
·
3,445 Posts
Did you flash the bios? What method did you use?

When you download the bios file, use a flash utility tool and then put the bios file you've just download on to the USB stick. Restart the computer and then have it boot to the USB stick.

From there, you should be able to flash.

Let me know if you need more help, I can provide images step by step if needed.
 

·
Registered
Joined
·
258 Posts
Discussion Starter #4
i dont have an option for flash utility tool,,,i have a 2gb flash stick...yeah show me step for step...lol
 

·
Intel/Nvidia
Joined
·
3,445 Posts
First go to the Gigabyte site and download the BIOS you want to flash. Format the USB stick if its not yet. Then proceed the download BIOS from gigabyte. Run that file and extract that to your USB stick.

Now on to the BIOS.

In Set Utility - Standard CMOS Features screen view - the following settings
Drive A = NONE
Floppy 3 Mode Support = DISABLED

Be sure that on the third image below where it says "Legacy USB Storage Detect" is enabled.

Restart the computer and boot it off from there. It should run and flash. After flashing, Clear CMOS and Load Optimize Settings. Then save your settings and reboot. You should have successfully flash your BIOS.
LL
 

·
Registered
Joined
·
258 Posts
Discussion Starter #6
Quote:

Originally Posted by raisethe3 View Post

Restart the computer and boot it off from there. It should run and flash. After flashing, Clear CMOS and Load Optimize Settings. Then save your settings and reboot. You should have successfully flash your BIOS.
Did all that but how do i get it to boot off of the usb? it just keep restarting windows
 

·
Intel/Nvidia
Joined
·
3,445 Posts
Make sure Legacy USB storage detect [Enabled] and also disable "quick booting".
 
1 - 7 of 7 Posts
Top