Overclock.net banner

1 - 4 of 4 Posts

·
Registered
Joined
·
219 Posts
Discussion Starter · #1 ·
I just picked up this card from NCIX today since it was on sale, but I have numerous issues with this card. Whenever I try to switch from any sound mode, whether it's entertainment, game, or audio creation, half the time my sound will disappear and I have to reset to get it back. This also happens If I try to plug in my headphones, and the sound will just disappear, if it didn't disappear when I plug my headphones in, it will disappear when I plug it out. There's also this very noticeable static/interference using the front panel audio through the header on the card, which doesn't happen with any other sound card I own.

I'm using the latest drivers from Creative, and I wiped any trace of audio drivers I had previously before installing the driver for the Titanium, I also tried the PAX drivers, but it didn't help either. Is my card just defective, or am I doing something wrong?
 

·
Registered
Joined
·
3,706 Posts
I had that happen after unplugging some headphones. I guess that they are serious when they say that make sure any applications are closed before messing with the different modes.
 

·
Registered
Joined
·
219 Posts
Discussion Starter · #4 ·
Well disabling my on-board sound in the BIOS seemed to have stop the sound from dropping. I moved my sound card from the PCIe1x slot to the bottom PCIe4x slot, and it seems to have reduced the static by a considerable amount, to a tolerable amount. Static is still pretty annoying though.
 
1 - 4 of 4 Posts
Top