Overclock.net banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6,845 Posts
Discussion Starter · #1 ·
Couldn't spot one, so here is a thread for discussion around Valve's Steam platform on Linux, now that it has been officially released!

Although it's only a .deb file from Valve, the beta is in the Arch Community repo (so, one would assume the official one is on its way soon), and I think there's a Gentoo port too. It's also in the Ubuntu Software Centre, for those afraid of the command line
tongue.gif


I had an issue installing it on my new Mint 14 install, but after enabling the "backports" & "romeo" (testing) repos, and a fresh reboot, I tried again and it was fine. It sucked in a few new packages - not sure if these were down to the new repos or the package itself, but it's cooking on gas now! Spent a few hourse last night playing FTL, it just feel SO GOOD to be gaming on Linux! BIG kudos to Valve for allowing cross-platform usage of the titles, you can bet you wouldn't see that on Origin if they took Linux on.

Minor bug though (not sure if anyone else has it) - when playing FTL, each time someone started playing a game (when I get a notification), it paused the game & lost focus, while the Steam FTL loading screen came up. This was annoying at first, but after maybe 15 seconds it disappeared and the game got focus back. However, after about 10 times of this happening, focus didn't come back, and I couldn't get it back - in fact, I couldn't get anything to focus. Had to kill X, which worked, in that it let me back into my DE, but "top" told me FTL was still running, but I've got no idea how I was supposed to get back into it (if it's even possible). A shame, as I hadn't saved it
frown.gif
 
1 - 4 of 4 Posts
Top