Overclock.net banner

1 - 6 of 6 Posts

·
Registered
Joined
·
346 Posts
Discussion Starter · #1 ·
Hey guys, i just got my stuff from performance-pcs, from what i see, there is no way to mount my UT60 on my 800D, they haven't supplied any screws for it and the ones that 800D came with do not fit on UT60's holes to mount it....any ideas? seriously acool.. :S
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #2 ·
I mean, they have only supplied those long, copper screws used to mount the fans on the radiator, i need shorter screws for mounting the radiator on my 800D .... jesus christ....
 

·
Registered
Joined
·
241 Posts
The mounting screws should come with the RAD.
thumb.gif

If you are still having trouble, contact the retailer and inform them that you have missing screws.
 

·
Registered
Joined
·
241 Posts
The long copper screw are there so that you can mount 2 sets of fans in p/p, while mounting the actual radiator, with just one screw.
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #5 ·
Quote:
Originally Posted by 512TBofRAM View Post

The long copper screw are there so that you can mount 2 sets of fans in p/p, while mounting the actual radiator, with just one screw.
Use what screws to mount the radiator? They have only supplied the copper screws for the fans, not for mounting the radiator.
 

·
Registered
Joined
·
165 Posts
Quote:
Originally Posted by Reystar View Post

Use what screws to mount the radiator? They have only supplied the copper screws for the fans, not for mounting the radiator.
Use the longer screws to mount the radiator to the bracket with fan in between. Should be like

Screw - RAD - FAN - Bracket
 
1 - 6 of 6 Posts
Top