Overclock.net banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1,674 Posts
Discussion Starter #1
I have a problem which I'm pretty sure is PSU related. I have an Ultra X-Finity(stop making fun of me, the reviews looked fine).

Every now and then, my rig will suddenly freeze. I reboot using the reset button, and when Windows loads, my temps show -99c through Speedfan. So I try to shutdown with the power button, but it doesn't work. Then I shut down through Windows, and the computer shuts down, but it is still powered(fans still spinning, LEDs on, etc.) Then I have to turn the PSU off and on to get my temps to show right again. After I do this it's fine(shuts down right, and all), but this has happened three times.

What kind of danger am I in? I want to save up for a new PSU without my dad knowing that it's not working so well, because I did ask for this for Christmas. Also, he'd probably buy me one if he thought my computer was in danger, and I'd feel kinda bad about that.

Is there a chance that this thing will explode on me, or is the freezing it?

Also, occasionally when I play WoW, I get a "memory exception" error and it crashes. I'm 100% prime and memtest stable. Could this be related to the PSU?

Thanks
-Amped
 

·
Premium Member
Joined
·
8,427 Posts
Check your voltages with a digital multimeter. I would recommend testing 12V and 5V at the video card, as well as 12V 5V and 3.3V at the motherboard connector. Also compare load voltages with idle voltages to see if you are getting fluctuation.
 
1 - 2 of 2 Posts
Top