Overclock.net banner

1 - 3 of 3 Posts

·
Top kek
Joined
·
3,595 Posts
Discussion Starter #1
Hellowpeople.

Yesterday, i was just fiddling around with my phone, and decided to run the nmap from it, while connected to the home router.

Unexpectedly, i saw, that both of my computers have port 22 open, which is for SSH.

Looking at that, i decided to give it a go, launched Terminal and :

ssh [email protected]
Password:
BlahBlah Security Key, Y/N >> Y

Aaand it worked.

C:\Windows\System32

Thats right, its like i started a remote CMD.

It didn't recognize any bash/sh commands, it worked only with normal WIndows ones.

The interesting thing is, that for some reason, i cant find ANYTHING at all about Windows 10 and SSH.

I am running Windows 10 Enterprise 1611 on both rigs.

Why are the SSH ports open, and its by default, since 1 of the rigs is almost clean install - last week i did a Reset for all settings and programs.

Another thing, how does it fare, launching programs and using HW resources via SSH (CMD)? I tried launching the XMR miner, but the rig crashed with BSOD : VIDEO_TDR_FAILURE.

Does it start a different session, which has limitted access to system resources?
 

·
Top kek
Joined
·
3,595 Posts
Discussion Starter #3
Quote:
Originally Posted by spinFX View Post

Yeah you aren't going to be able to use bash commands on a windows shell.
SSH is not linux specific.
build 14352 introduced ssh server in win10
probably not a bad idea to block the port back at your router.
I still have to run a check on the router open ports from outside. I think there will be only 1 or 2 ports, but ssh shouldn't be part of them.

Anyway, how does the resource are used when trying to reach them over SSH? For example, can i start a game via the SSH? I wont need the output to be redirected to the rig, but will it run on the targeted PC?
 
1 - 3 of 3 Posts
Top