Overclock.net banner

1 - 7 of 7 Posts

·
Registered
Joined
·
835 Posts
Discussion Starter #1
I currently have a weird problem. It seems to have something to do with the display driver, nVidia's driver 310.54. I got Black Ops II today from Steam, but it had dips from 60 to 30 fps which made playing inconvenient in 310.33. So why not install 310.54 with the great news nVidia presented. I installed the driver with my usual routine. First uninstalling the PhysX driver and then the Display driver by nVidia (I always leave the 3D driver and other things I don't use out). Then restarted, Windows activated it's default driver (everything's still fine). Then I installed 310.54 and after a reboot the Windows 8 logo comes up with the rotating thingies and as a runner up nothing but a black screen. What do I have to do? Can I try Safe Mode to uninstall the drivers and go back to a previous driver or try again? I also would like to know if others have this problem too.<br><br>
My video card is the GTX 670 FTW.<br><br>
Also I noticed something weird. My Logitech G510 lights go out and on, out and on while the black screen is still there. It's like the nVidia drivers created a blockade so the rest of the drivers can't load for the keyboard and etc. I have the latest Logitech drivers and never messed with anything. So, I absolutely don't understand why a situation like this occurs.<br><br><b><i><span style="text-decoration:underline;">*FIXED*, read next post.</span></i></b>
 

·
Registered
Joined
·
835 Posts
Discussion Starter #2
<a href="http://forums.guru3d.com/showthread.php?p=4453102" target="_blank">http://forums.guru3d.com/showthread.php?p=4453102</a><br><br><b>"</b>I installed these without any major hiccups. Noticed on the GeForce.com forum that they've identified what caused the black screen/flickering issue with the v310.33 beta drivers on Windows 8:<br><br>
1) Flickering Screen/Black Screen After Installing R310.33/R310.54 Drivers on<br>
Windows 8<br><br>
Issue<br>
After installing the R310 driver on Windows 8, the subsequent reboot results in a black or<br>
flickering screen.<br><br>
Root Cause<br>
This occurs because Windows Update performed a background installation of a Release<br>
304 driver, which requires a reboot to complete the installation. After installing the<br>
Release 310 driver and then rebooting the system, installation of both the Release 304 as<br>
well as the Release 310 is completed, resulting in conflicting driver binaries and the black/<br>
flickering screen.<br><br>
Workaround - Prevention<br>
To avoid the issue, reboot the system before installing the Release 310 driver.<br>
Alternately, you can check the driver status under the Device Manager and perform the<br>
reboot if the Device Manager indicates that a restart is needed. Then install the driver.<br><br>
Workaround - Recovery<br>
If you did not perform the necessary reboot prior to installing the driver and now<br>
encounter the black screen, do the following:<br>
1 Reboot in Safe Mode.<br>
2 Uninstall the driver.<br>
3 Disconnect from the internet and then restrt the system.<br>
4 In normal mode, install the new driver.<b>"</b> - The Workaround - Recovery from Darren Hodgson fixed my problem people. After all it appears some people had it too.
 

·
Registered
Joined
·
3,089 Posts
I cannot get into safe mode. I read that the way to do this is to hold shift and press f8 but this just makes it ask me which device to boot from, or enter the bios. If I continue the boot and keep pressing it, it either restarts or keeps going with the boot and goes back to the flickering screen.
 

·
Registered
Joined
·
970 Posts
<div class="quote-container" data-huddler-embed="/t/1326858/windows-8-boots-but-shows-only-black-screen-with-new-nvidia-driver-310-54/0_50#post_19062839" data-huddler-embed-placeholder="false"><span>Quote:</span>
<div class="quote-block">Originally Posted by <strong>Skoobs</strong> <a href="/t/1326858/windows-8-boots-but-shows-only-black-screen-with-new-nvidia-driver-310-54/0_50#post_19062839"><img alt="View Post" class="inlineimg" src="/img/forum/go_quote.gif"></a><br><br>
I cannot get into safe mode. I read that the way to do this is to hold shift and press f8 but this just makes it ask me which device to boot from, or enter the bios. If I continue the boot and keep pressing it, it either restarts or keeps going with the boot and goes back to the flickering screen.</div>
</div>
Yep had the same problem,i just did a format and did what battleaxe did.Works ok now.
 

·
Registered
Joined
·
3,089 Posts
A format?
 

·
Registered
Joined
·
3,089 Posts
Just got it to work. Apparently there is a point at which you have to stop pressing f8 lol
 

·
Registered
Joined
·
267 Posts
I have this problem aswell.<br><br>
Any NVIDIA Driver after 327.23 has a chance to cause a Black/White Screen after the Windows Loading Screen.<br><br>
Even on a Clean Windows install with the latest 337.50 it happens.<br><br>
So i'm stuck on 327.23.
 
1 - 7 of 7 Posts
Top