Overclock.net banner

1 - 6 of 6 Posts

·
Old Timer
Joined
·
4,895 Posts
Discussion Starter #1
I installed Warcraft III: The Frozen Throne with WINE on my Ubuntu instalation. It runs fine with the -opengl switch, but durring the game, it jerks and lags, and seems related to the audio. When I closed the program, I found this error in the terminal:

Code:

Code:
err:wave:DSDB_MapBuffer Could not map sound device for direct access (Input/output error)
err:wave:DSDB_MapBuffer Please run winecfg, open "Audio" page and set
"Hardware Acceleration" to "Emulation".
fixme:sync:CreateIoCompletionPort (0xffffffff, (nil), 00000000, 00000000): stub.fixme:imm:ImmAssociateContextEx (0x10028, (nil), 16): stub
winecfg
ALSA lib seq_hw.c:456:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory
Link points to "/tmp/ksocket-ross"
can't create mcop directory
When I tried to open the Audio tab in winecfg, it closed instantly, with this error:

Code:

Code:
ALSA lib seq_hw.c:456:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory
Creating link /home/ross/.kde/socket-ross-laptop.
can't create mcop directory
Please help!
 

·
Premium Member
Joined
·
2,402 Posts
Hrm. I get the same error when I hit the Audio tab in winecfg, but mine doesn't close.

I assume you're running alsa...are there any programs playing music running? Strange. Gonna take all night to figure it out while I sleep lol...night.

Might just be installing wc3 tomorrow
 

·
Registered
Joined
·
491 Posts
Try running with out sound and see if it works fine. If it works fine tell me and I can tell you how to fix it. I have to go grab my computer with Warcraft III on it from the car to see exactly how I set my sound up.

I had sound problems as well but it was easy enough to fix.

Oh you do know about winecfg right?
type: /winecfg
Then see how the game runs without sound. Im 95% sure this problem is easily fixable.

Im guessing you tryed doing what the error message said before you posted this?
err:wave
SDB_MapBuffer Please run winecfg, open "Audio" page and set
"Hardware Acceleration" to "Emulation".
 

·
Old Timer
Joined
·
4,895 Posts
Discussion Starter #4
Well, the good new is, I got the audio tab to respond, thanks to some googling! Bad new is, even after I set it to "Emulation", I still get the studdering
How would I go about disabling audio to see if that is the problem?
 

·
Registered
Joined
·
491 Posts
Quote:


Originally Posted by SoaDMTGguy

Well, the good new is, I got the audio tab to respond, thanks to some googling! Bad new is, even after I set it to "Emulation", I still get the studdering
How would I go about disabling audio to see if that is the problem?


It would of thought it would be obvious. Set it to None. Also unchecking the check boxes for sound types would help. Up where you see things like ALSA and things uncheck all those textboxes.
 

·
Registered
Joined
·
491 Posts
When ever you do choice to run sound make sure only the OSS check box is checked. Some times if Emulation causes problems setting it to "basic" instead helps.
 
1 - 6 of 6 Posts
Top