Overclock.net banner

1 - 20 of 28 Posts

·
Registered
Joined
·
1,222 Posts
Discussion Starter · #1 ·
Hey guys, my first build log here on the watercooling sub-forum. Never really post any pics when i did my first loop in my modded rfish. But this seems like it would be interesting to post since i'll be porting almost everything over to my new custom Monotone tech station that i build.

Anyway to start it off, i like to first show the finish product of my tech station.


The station itself is pretty much built to incorporate a dual watercooling loop setup that holds 2x 3x120 size radiators on level 2.

I'll be using my classified setup most of the time.. and that's what i'll install on my bench


Parts
  • CPU- Core i7 920 D0
  • Motherboard- Evga x58 Classified e759
  • Graphics- ATI HIS HD5970 **Awaiting arrival**
  • Ram- G.Skill ddr3 2000mhz Tridents
  • PSU- 1x Enermax Galaxy 1250w and 1x Corairs 1000HX
Water cooling Parts
  • Rad- 1x Swiftech MCR320 and 1x Thermochill PA120.3
  • Pumps- 2x Laing D5 Vario
  • Fans- 3x 1850RPM Gentle Typhoons with 25mm shrouds and 3x Panaflo Ultra 38mm fans with 38mm shrouds
  • Cpu block- Swiftech Apogee GTZ with 1366 brackets
  • Mosfet Block- Bitspower Black Freezer EI58DP II
  • Chipset Block- Bitspower Black Freezer EIX58NSC
  • GPU Block- To be Pending
  • Res- 1x EK Multi-res 150 and 1x Swiftech micro-res
  • Fittings- Bitspower True Silver Compression fittings and assorted EK high blow barbs
  • Tubing- Tygon R3400 Black UV resistant 1/2" ID and 3/4" OD
Hopefully, i won't regret tearing apart my old loop.
 
  • Rep+
Reactions: ira-k

·
Registered
Joined
·
1,222 Posts
Discussion Starter · #2 ·

·
Registered
Joined
·
1,222 Posts
Discussion Starter · #3 ·
Day 1- Parts arrival.


After numerous phone calls/ emails to Gary @ sidewinder.. it's either this part was out of stock delaying shipping or that when the part is back in stock.. this other item that i had order is out of stock. I eventually cancelled my order and got it from jab-tech and performance PCs. Which got it out to me in just two day. Wasted 2 weeks with Sidewinder.

/sigh

Anyway. Most of the parts are here and i'll show it to you guys in picture format.

Bitspower North/Southbridge waterblock. And Mosfet block for my Evga e759 Classified.


Upper side of the blocks, freaking sexy as hell



Base of the waterblock, mirror finish



EK 150mm Res along with cyclone stopper attachment



Swiftech MCR320 radiator. This rad is going to handle cooling the mosfets, Northbridge, southbridge, as well as my yet to arrive ATI HD5970
On the background, 3x 1850rpm Gentle Typhoons fans, some of the hardest to find fans on the market today (it's virtually impossible to find these in stock.. i was stalking alot of site for weeks before i finally found them :lol: ) The impressive amount of static pressure that these fans generate makes them perfect for my rad



Couple of Bitspower True Silver Compression fittings (the ones with silver lined interior for microbe ownage) :hello: algae. Also not pictured, tons of EK high flow barbs for other parts of the loop where it isnt' visible. Can't afford these compression fittings everywhere
.


And of course, this time around.. i splurge and got a ton of the best tubings ever made for watercooling. Tygon R3400 uv resistant black tubings with 1/2" ID and 3/4" OD. The walls are thick as hell



And parts from my old loop.

Apogee GTZ
Still works well enough for me.


Microres


These beefy, crazy Panaflo ultras, i have 6 total.. and i broke two of them
Broke the blades



My old PA120.3 radiator (the one with the 25mm fan spacing)
 

·
Registered
Joined
·
3,055 Posts
the sex the sex the sex is what this is... NICE TECH STATION BRO!
 

·
Registered
Joined
·
1,222 Posts
Discussion Starter · #8 ·
Hehe, thanks guys. I'll probably work on it again tonight once i get home from work. Buttsecks FTW
 

·
Registered
Joined
·
1,222 Posts
Discussion Starter · #10 ·
Eh.. watercooling club?

Edit: NVM.. i'm a ******.. didn't notice the thread
 

·
Registered
Joined
·
1,222 Posts
Discussion Starter · #13 ·
Day 3- Half way done

Didn't get to work on it at all yesterday, but i did manage to get pretty much half of it done tonight


Meh, you guys probably want the pics more so here it is


Naked classified, Anyone else not getting turned on by a naked board?



NB/ SB and Mosfet blocks installed. It's so sexi



Bitspower True Silver compression fittings installed!


Can't forget about my Apogee GTZ



Measuring the cutout hole for the rad on the back of the tech station. I didn't do it when i first mod it since i dunno what size rad i was gonna get :[


Now the colors are all fugly
And i broke one of the EK multi res clips
Double phail.


This is what god made sharpie for



Looks like it was painted
I has GG coloring skills?



On to mounting the gentle typhoons and shrouds on the back of the station


A look from the inside


The back view


Close-up


And finally.. one of the rad mounted



Thanks for watching! That's it for the night. More tomorrow
 

·
Registered
Joined
·
1,222 Posts
Discussion Starter · #15 ·
Hm.. sort of a last minute thing. I forgot to order a drain port / tee. I'm going to pick something up from home depots since i don't want to wait anymore.

Does anyone know if a brass barb tee like this would impact performance/ flow? Like is it restrictive.

 

·
Premium Member
Joined
·
2,485 Posts
I am running one of those in my loop right now. They are actually not bad at all for tees. Much better than the nylon fittings. Probably better than most other tees, actually.
 

·
Registered
Joined
·
1,222 Posts
Discussion Starter · #17 ·
Quote:


Originally Posted by Sun
View Post

I am running one of those in my loop right now. They are actually not bad at all for tees. Much better than the nylon fittings. Probably better than most other tees, actually.

Thanks for the input. +rep.

Also.. impressive job you did there with the pa120.3
 

·
Registered
Joined
·
1,222 Posts
Discussion Starter · #18 ·
Day 4: What? No hose clamp you say?

Was originally hoping to have my loop leak tested tonight... only to realize i didn't have any hose clamps.
I pretty much have everything already set up. I'll run out and get some hose clamp first thing tomorrow morning and see if i can finish it then too


Anyway.. the progress tonight.

Went ahead and mount my PA120.3 to the front panel of the tech station. I couldn't find anywhere that sold 6/32" 4.25" screws so i had to fab my own



All the fans attached.


I'm loving the way it looks. The extra spacing between fans for the PA120.3 makes it look a whole lot better.
The black on black is a KILLER



Then on to measuring and cutting the tubings. My weapon of choice ^_^


One mounted from pump to res


The tubing on the rad level. Look at all that tubing traffic.



Connect the mosfet and nb blocks



This is probably how the tubing will be layout on the top level. The way i have it routed is so i can remove the CPU block and install a LN2 pot when i need to bench.. yet still have water cooling the mosfet and nb/sb area



Yep, that's it for tonight.

P.S- You guys like how i routed the tubing thru the wood?
 

·
Registered
Joined
·
1,222 Posts
Discussion Starter · #20 ·
Day 5: Yep! Still not done


Still didn't get to finish it today. This is phail upon phail.

No pics today.. but a nice little video
Enjoy till my next update!




 
1 - 20 of 28 Posts
Top