Overclock.net banner

1 - 20 of 59 Posts

·
Registered
Joined
·
2,022 Posts
Discussion Starter #1
Hi Everyone,

I noticed world of warcraft is a strange beast in terms of performance, even with my new 5770 1gb it chugs in Dalaran on modestly high settings. It also gets sluggish when there's alot of action in raids. I was wondering if others have had performance issues on decent systems?

I'm thinking it might be more related to server side issues and not my system, any thoughts?
 

·
Registered
Joined
·
4,865 Posts
Wow is horribly coded for one. Second, it's very CPU dependent.

I know where you're coming from, though. My i7 with a GTX470 has the same issues. It's just WoW.
 

·
Loosing Vision
Joined
·
1,892 Posts
I have a ATI 4650 in my other computer e6300 duo core and it runs at ultra no issues.

I think you should look at the hard drive or optimize the system. Is the drive under a lot of heat?
My 5750's run at ultra as well no issues.

The don't call it Lagaran for nothing.
 

·
Premium Member
Joined
·
4,305 Posts
Quote:

Originally Posted by BinaryBummer View Post
I have a ATI 4650 in my other computer e6300 duo core and it runs at ultra no issues.

I think you should look at the hard drive or optimize the system. Is the drive under a lot of heat?
My 5750's run at ultra as well no issues.
Check this out possibly, a lot of data is pulled off of the harddrive when playing. I play through the wifi on my phone and can monitor how much data I use, it's amazing how little data use you go through with WoW.

I run everything maxxed on my 4890 and 720 np, I also have the WoW folder saved onto a SSD.
 

·
Premium Member
Joined
·
8,388 Posts
Lower the shadows, they're horribly optimized. Otherwise try a fresh driver install.

Quote:

Originally Posted by BinaryBummer View Post
I have a ATI 4650 in my other computer e6300 duo core and it runs at ultra no issues.

I think you should look at the hard drive or optimize the system. Is the drive under a lot of heat?
My 5750's run at ultra as well no issues.

The don't call it Lagaran for nothing.
Most people run WoW on intergrated. There's a reason their computers lag.

Quote:

Originally Posted by Pao View Post
Check this out possibly, a lot of data is pulled off of the harddrive when playing. I play through the wifi on my phone and can monitor how much data I use, it's amazing how little data use you go through with WoW.

I run everything maxxed on my 4890 and 720 np, I also have the WoW folder saved onto a SSD.
1280x720 is a joke in terms of resolution.
 

·
Registered
Joined
·
2,022 Posts
Discussion Starter #7
My windows install is about as optimized as its gonna get, all unneeded services disabled, etc...And my hard drive is partitioned, defraged. Maybe put wow on its own partition?

Driver issue with the gpu perhaps, I upgraded from a 9800gt. Maybe clean out all graphics drivers and go from there.

I've monitored my cpu usage and it stays at about 74%, although I read in a blizzard faq that wow utilizes 3 cores, so maybe that's why. And my gpu usage never maxes out.
 

·
Registered
Joined
·
3,485 Posts
i had the same problem with my 5770 as you are having, when i had it. I never had a problem with my 8800gts 512/470 not sure if it is a driver issue or what but seems like ati has not fixed this yet
 

·
Registered
Joined
·
2,022 Posts
Discussion Starter #10
I think I'm just gonna return my 5770 and get a 460 anyway, maybe it's more nvidia friendly. I didn't see much of a performance difference at all between my 9800gt and 5770, sad but true!
 

·
Registered
Joined
·
4,992 Posts
Strange, I have like the exact same system as you, even the same resolution, I have all setting ultra and I never lag. I havn't checked the fps, but its very smooth and I never notice any drops. My performance increase from 8800gt to hd5770 was very noticeable for me.
 

·
Premium Member
Joined
·
5,329 Posts
It's your sad RAM and CPU.

I am running this game maxed (with console settings for more eyecandy with max shadows etc) and I get more than 100 fps in dalaran with Eyefinity.. with a single 5970 (stock for wow) Now on the other hand there are some pretty ******ed settings in beta which brings my system to its knees (they are just bugged) there is this Sun something option that can make ur fps go from 300 permanent to 50.. bugged beta is bugged.
 

·
Premium Member
Joined
·
4,084 Posts
Quote:

Originally Posted by BinaryBummer View Post
I have a ATI 4650 in my other computer e6300 duo core and it runs at ultra no issues.

I think you should look at the hard drive or optimize the system. Is the drive under a lot of heat?
My 5750's run at ultra as well no issues.

The don't call it Lagaran for nothing.
What resolution were you running? It couldn't have been anything large as my E8600 has trouble with WoW.

Here are some test results (though not in a formal format).

I've tested WoW on everything from my E8600 to an i7, with everything from a 9800GT to one of my GTX 285's.

WoW is heavily CPU dependant. You can run it with a 9800GT no problem, provided you have a very fast CPU.

HDD has some impact as well. But only to the point where things are loaded. A SSD will help load everyone in Dalaran faster, it will not help do all the processing to show you what those people are doing. Once they are loaded, the task is almost 100% CPU oriented.

My advice, if you plan on playing WoW, drop that C2Q and get a C2D and clock the crap outta it. When I played WoW, I was able to max it at 4.8Ghz with FPS drops every once in a while in heavy areas but once it was all loaded I would run 45+ fps.

WoW only uses 2 threads. Anyone who tells you different hasn't done the proper research and thinks they can flag the other 2 threads to work. While you can flag to be usable by WoW, WoW is simply not coded to use those threads and therefore will not. I've done real world testing and monitoring of thread usage.

Keep in mind, this may change with the upgrade they are planning for Cata, though I don't know if they will increase thread usage, I know they are increasing the texture quality/size and adding a few new effects in.
 

·
Registered
Joined
·
936 Posts
just get the gtx 460 1gb man im sure u will be more happy with that. i do like the 5770 as well but i would rather recommend the gtx 460 if i'm going to spend almost the same price when it comes to $$...
 

·
I.T. Specialist III
Joined
·
4,670 Posts
Quote:

Originally Posted by .:hybrid:. View Post
Strange, I have like the exact same system as you, even the same resolution, I have all setting ultra and I never lag. I havn't checked the fps, but its very smooth and I never notice any drops. My performance increase from 8800gt to hd5770 was very noticeable for me.
Agreed.
Some people just aren't techies and don't notice things unless it falls on thier heads.
 

·
Premium Member
Joined
·
4,305 Posts
Quote:

Originally Posted by justarealguy View Post

1280x720 is a joke in terms of resolution.
That response was


My 23" monitor is even listed in my system info, along with my processor which is named 720....

I run everything at all the way high, except shadows, and don't lag anywhere...further more I play off of the wifi my cell phone puts out, no problems in raids, pvp, or Dalaran...ever.
 

·
Premium Member
Joined
·
4,403 Posts
Wow...lots of misinformation in here....check my system...I still lag in Dalaran with everything maxed sometimes...its the terrible graphics coding, more specifically the shadows are the biggest culprit. Turn off or down all the way shadows and you will see a huge difference. There is nothing wrong with your hardware.
 
1 - 20 of 59 Posts
Top