Overclock.net banner

1 - 20 of 22 Posts

·
Premium Member
Joined
·
7,187 Posts
Discussion Starter #1
Well, I reinstalled Fedora 10 today.

I am now using KDE instead of Gnome. Kmixer only shows my onboard (HDA Intel) and not my Xonar (C-Media).

Did Gnome have something that KDE doesn't have that caused my Xonar to work?
 

·
Registered
Joined
·
1,560 Posts
Go to your "start menu" in KDE. Then click on System ---> System Settings ---> Multimedia. From there, you will probably see several audio card options along with Pulseaudio. Just put your audio card at the top of the list for all applications.
 

·
Premium Member
Joined
·
7,187 Posts
Discussion Starter #3
Attachment 100596

No Multimedia in system settings, just Sound, where I was before.
LL
 

·
Registered
Joined
·
1,560 Posts
First update your system. It looks like you're still running KDE 4.1. KDE 4.2 should install automatically when you update.
 

·
Premium Member
Joined
·
7,187 Posts
Discussion Starter #5
Hm, that's true, I didn't think of that. I can't remember if I had to update before my sound worked before. I was putting it off because it takes so long >_<

I'll try updating when I get home later today, thanks.
 

·
Premium Member
Joined
·
7,187 Posts
Discussion Starter #6

·
Registered
Joined
·
1,560 Posts
That's odd. If the Gnome version of Fedora detected the Xonar, then the KDE version should as well. Just out of curiosity, what shows up when you click on advanced devices on the bottom left of that window?
 

·
Premium Member
Joined
·
7,187 Posts
Discussion Starter #9
If I click advanced it shows me:
PulseAudio
HDA Intel (ALC88 Analog)
Default, PulseAudio Sound server
HDA Intel (ALC88 Digital)
HDA Intel, ALC888 Digital (IEC958 (S/PDIF) Digital Audio Output
?
?

I tried moving the two ?s to the top thinking they might be the Xonar, but still no sound.
I don't know why, last install when I had Gnome it was detected as C-media, I just had to make it the default.
 

·
Registered
Joined
·
1,560 Posts
You might have to install the driver for that card from the repos. What is the exact model of the card? You can probably google and find out exactly which driver it would take. Then just search the package manager for it.

And as Gavenator said, try disabling the Intel onboard sound via your BIOS. Having my onboard sound enabled has caused me similar headaches.
 

·
Premium Member
Joined
·
7,187 Posts
Discussion Starter #11
Xonar HDAV1.3

I highly doubt I'd have to install any drivers for it, since I didn't with my original Fedora 10 install..

I'll try disabling my onboard sound and see if that works.
 

·
Registered
Joined
·
1,560 Posts
Yeah I don't recommend using Pulseaudio. Unless you need a sound server, there is no point in it. Just use the Alsa driver for your card.
 

·
Premium Member
Joined
·
7,187 Posts
Discussion Starter #14
Quote:


Originally Posted by Gauvenator
View Post

try:

Code:
Code:
[B]root#[/B] modprobe snd_virtuoso
then check pulseaudio...you might have to restart pulseaudio after that tho...i dont use pulsaudio.

That command didn't do anything. (see first thumbnail.)

Quote:


Originally Posted by thiussat
View Post

Yeah I don't recommend using Pulseaudio. Unless you need a sound server, there is no point in it. Just use the Alsa driver for your card.

Pulseaudio or not, the card just plain isn't being detected. I turned off my onboard audio and now there's just nothing. It used to say Intel HDA and list all the outputs, now it just says ALSA and Pulseaudio. (see 2nd thumbnail.)

This is off of another fresh install. I thought that it might work if I simply reinstalled a 2nd time, since the first time I installed Fedora 10 it worked with no problem at all. Still not working, and I installed both Gnome and KDE this time.

 

·
Registered
Joined
·
2,262 Posts
Quote:


Originally Posted by Redmist
View Post

That command didn't do anything. (see first thumbnail.)

Pulseaudio or not, the card just plain isn't being detected. I turned off my onboard audio and now there's just nothing. It used to say Intel HDA and list all the outputs, now it just says ALSA and Pulseaudio. (see 2nd thumbnail.)

This is off of another fresh install. I thought that it might work if I simply reinstalled a 2nd time, since the first time I installed Fedora 10 it worked with no problem at all. Still not working, and I installed both Gnome and KDE this time.

That command loads the module for the xonar; it should be available in alsamixer after that. If not...I think you will have to play around with alsactl or alsaconf to set the default card. I would try alsaconf first; it has solved a similar issue for me before.
 

·
Premium Member
Joined
·
7,187 Posts
Discussion Starter #16
Quote:


Originally Posted by Gauvenator
View Post

That command loads the module for the xonar; it should be available in alsamixer after that. If not...I think you will have to play around with alsactl or alsaconf to set the default card. I would try alsaconf first; it has solved a similar issue for me before.

I just don't understand why it isn't autodetecting it, the first time I installed Fedora 10 this is what I got, and I didn't have to do anything at all!

 

·
Registered
Joined
·
2,262 Posts
Quote:


Originally Posted by Redmist
View Post

I just don't understand why it isn't autodetecting it, the first time I installed Fedora 10 this is what I got, and I didn't have to do anything at all!



when you load the driver do you get the xonar in that program?
 

·
Premium Member
Joined
·
7,187 Posts
Discussion Starter #18
Quote:


Originally Posted by Gauvenator
View Post

when you load the driver do you get the xonar in that program?

Nope, only the HDA Intel
 

·
Premium Member
Joined
·
7,187 Posts
Discussion Starter #20
Quote:


Originally Posted by Gauvenator
View Post

hrmph post the output of this: lspci | grep audio


Code:
Code:
04:04.0 Multimedia audio controller: C-Media Electronics Inc CMI8788 [Oxygen HD Audio]
It's there, just not working for some reason.
 
1 - 20 of 22 Posts
Top